Closed Bug 849290 Opened 7 years ago Closed 7 years ago

[B2g][Contacts] Not able to add picture from Gallery, gallery is unresponsive

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-)

VERIFIED WORKSFORME
blocking-b2g -

People

(Reporter: nkot, Unassigned)

References

Details

(Keywords: smoketest)

Attachments

(1 file)

Repro Steps:
1) Updated to Unagi Build ID: 20130308070202
2) Open Contacts app
3) Create a new contact (or select a contact w/o picture)
4) Tap "Add Picture" button
5) Select to add picture from the Gallery
6) Select any image to add as contact picture once it loads

Expected:
- user can successfully select a picture from a gallery and add it to the contact

Actual:
- gallery is unresponsive

Repro frequency:
100%, 3/3 devices

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/94927529a55f
Gaia: 87801b12cd3aac153fae84844da8f1e6455ea679

Notes:
*Gallery app works properly when opened from the homescreen
David - Any ideas?
blocking-b2g: --- → leo?
Flags: needinfo?(dflanagan)
Component: Gaia::Contacts → Gaia::Gallery
QA Contact: isabelrios → jhammink
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/94927529a55f
Gaia   87801b12cd3aac153fae84844da8f1e6455ea679
BuildID 20130308070202
Version 18.0


Tested in a Unagi, Was able to reproduce this build. Gallery keeps loading and is unresponsive.
Seeing this in our Unagi engineering build from today, too.
The bug was caused by gaia code and was fixed with gaia commit ab1d2c275643769a1854c49bfe5a3db2aa972542. 

It is also fixed in the latest master branch of gaia of the commit a2a9909391abf8d76dcac6b698b141aaf70c6be4.

It was introduced by commit 7359be50cc60e737d44ea0d0c0dff29fc2a1a95d(https://github.com/mozilla-b2g/gaia/commit/7359be50cc60e737d44ea0d0c0dff29fc2a1a95d#L0R673). When user selects a picture to add, the gallery fails to open the image editor with the following code.
  
  loader.load('js/ImageEditor.js', function() {
  ...

That commit merged the patch of bug 846220([OPEN_][Gallery]Two images are overlayed in edit mode.), which depends on bug 841251(Implement a shared lazy loader). But bug 841251 didn't landed in advance. 

So after the blocking bug 841251 landed in commit ab1d2c275643769a1854c49bfe5a3db2aa972542, the bug was fixed.
So the bug was caused during uplift, it looks like. Thanks for diagnosing it, Yuan.

I suppose that if I nominate a bug for uplift, I should test it on that branch so that this kind of thing doesn't happen!
Flags: needinfo?(dflanagan)
afaik bug 841251 didn't land on v1-train yet, so I'd say this bug is not fixed, and Bug 846220 should be backout from v1-train and v1.0.1 until bug 841251 lands to these branches.

David, what do you think ?
Flags: needinfo?(dflanagan)
Julien,

Thanks for letting me know about this...  Yes, I guess we should back that out, or manually merge it.  Is that something I should do?  Do we reopen 846220?
Flags: needinfo?(dflanagan)
David, thanks for your answer.

No need to reopen the other bug, we just need to backout and fix the appropriate "status" flag.

I'll comment there :)
should we dup then ? or resolve invalid or something else ?
Bug 841251 has landed on v1-train, so the bug is fixed.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
The issue no longer appears to be occurring on an Unagi device running the following build:

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/af9270e8f205
Gaia: a78ebf426840b5ef08c0cc3e437ad30aba3e2528
Build: 20130318070202

User is now able to successfully add a photo from the gallery to a contact.

Verifying as fixed.
Status: RESOLVED → VERIFIED
comment 12 should be verified WorksForMe, since there's no patch to retest.
blocking-b2g: leo? → -
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.