Crash while sending an SMS message [@GlobalWindowImpl::DropTimeout]

RESOLVED DUPLICATE of bug 55459

Status

()

RESOLVED DUPLICATE of bug 55459
18 years ago
18 years ago

People

(Reporter: bugz, Assigned: jst)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

18 years ago
Probably browser general is wrong category (needs to go probably who deals with
timers).

Using Win98 SE
Using Netscape 6.1 Preview Release 1 
I managed to reproduce it twice in a row on my system:
1. go to http://www.messaging.sprintpcs.com/sms/ site
2. enter the information (I think crash happened after I entered the message)
3. I don't believe you need to even press

talback ID1:
http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=16&cp=1&ck1=SUser+email+address&cd1=%25marek%40netscape%2Ecom%25&co1=like&bbid=31515902
talkback ID2:
http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=16&cp=2&ck1=SUser+email+address&cd1=%25marek%40netscape%2Ecom%25&co1=like&bbid=31515752

Both incidents have the following stack traces:

    GlobalWindowImpl::DropTimeout  
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 3499]       
 nsGlobalWindow_RunTimeout  
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 3641]       
 nsTimer::Fire  
[d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp, line 196]   
     nsTimerManager::FireNextReadyTimer  
[d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimerManager.cpp, line
117]         FireTimeout  
[d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp, line 91]    
    KERNEL32.DLL + 0x2317 (0xbff72317)             FireTimeout  
[d:\builds\seamonkey\mozilla\widget\timer\src\windows\nsTimer.cpp, line 51]    
    USER32.DLL + 0x3bb5 (0xbfc03bb5)             0x16280003             0x8bf2468b
wfm with win2k build 20010609.. (CVS)
Component: Browser-General → DOM Level 0

Comment 2

18 years ago
WORKSFORME winME 2001060704

Comment 3

18 years ago
fwiw, I filed Bug 79920 about a crash in my xlib build which has a similar 
call stack.
Assignee: asa → heikki
Keywords: crash
QA Contact: doronr → desale
Summary: Crash while sending an SMS message → Crash while sending an SMS message [@GlobalWindowImpl::DropTimeout]
I tested with the same build Marke did on W2k, and I could not reproduce. I left
the machine for a little while and when I came back it had crashed. TBI
31584305. The stack is different.

Over to default owner, although I guess this might be worksforme...

Stack Trace:
ntdll.dll + 0x4b9b1 (0x77fcb9b1)
ntdll.dll + 0x4b733 (0x77fcb733)
MSVCRT.DLL + 0x1d92 (0x78001d92)
JS_free [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 1429]
js_FinalizeObject [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 1774]
js_GC [d:\builds\seamonkey\mozilla\js\src\jsgc.c, line 1221]
js_ForceGC [d:\builds\seamonkey\mozilla\js\src\jsgc.c, line 944]
JS_GC [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 1620]
JS_MaybeGC [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 1640]
DoPostScriptEvaluated
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp, line 70]
nsXPCWrappedJSClass::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp, line 1386]
nsXPCWrappedJS::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjs.cpp, line 427]
PrepareAndDispatch
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp,
line 102]
SharedStub
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp,
line 124]
nsXULControllers::GetControllerForCommand
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULControllers.cpp, line
142]
nsFocusController::GetControllerForCommand
[d:\builds\seamonkey\mozilla\dom\src\base\nsFocusController.cpp, line 362]
nsXULCommandDispatcher::GetControllerForCommand
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULCommandDispatcher.cpp,
line 414]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 139]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 1837]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1242]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 809]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2703]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 825]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 897]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3322]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 937]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 140]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1120]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
2090]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3631]
nsXULCommandDispatcher::UpdateCommands
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULCommandDispatcher.cpp,
line 369]
GlobalWindowImpl::UpdateCommands
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 2364]
nsFocusController::UpdateCommands
[d:\builds\seamonkey\mozilla\dom\src\base\nsFocusController.cpp, line 124]
nsFocusController::SetFocusedElement
[d:\builds\seamonkey\mozilla\dom\src\base\nsFocusController.cpp, line 107]
nsFocusController::Blur
[d:\builds\seamonkey\mozilla\dom\src\base\nsFocusController.cpp, line 293]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1609]
nsWindowRoot::HandleChromeEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsWindowRoot.cpp, line 180]
GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 596]
nsXULDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 1994]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3619]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3612]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3612]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3612]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3612]
nsXULElement::HandleChromeEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 4595]
GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 596]
nsDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 2871]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1660]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1654]
nsHTMLTextAreaElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLTextAreaElement.cpp,
line 620]
nsEventStateManager::SendFocusBlur
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 3650]
nsEventStateManager::SetContentState
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 3422]
nsHTMLInputElement::SetFocus
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLInputElement.cpp,
line 705]
nsGenericHTMLElement::SetElementFocus
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp,
line 4115]
nsHTMLInputElement::Focus
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLInputElement.cpp,
line 660] 
Assignee: heikki → jst

Updated

18 years ago
Keywords: nsenterprise

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 55459 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@GlobalWindowImpl::DropTimeout]
You need to log in before you can comment on or make changes to this bug.