Closed Bug 849332 Opened 7 years ago Closed 7 years ago

Change - Allow user to reset "not for this site" preference

Categories

(Firefox for Metro Graveyard :: General, defect)

x86_64
Windows 8
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 845484

People

(Reporter: jbecerra, Unassigned)

References

Details

Tested on 2013-03-08 on nightly built from http://hg.mozilla.org/mozilla-central/rev/cb432984d5ce

While verifying bug 838734 if you click on the "not for this site" preference when given the option to save a password, I found no way to toggle that preference back so I could save the password for, in this case, facebook.

Steps:
1. Go to facebook.com
2. Enter your credentials.
3. When the password info bar comes up, select "Not for this site"
4. Log out and enter your password again and try to have it remember your password.

Expected: There should be a way in the Options to toggle this preference for this site.

Actual: It's not obvious how to do it.
Blocks: metrov1it4
QA Contact: jbecerra
Summary: change -allow user to reset "not for this site" preference → Change - Allow user to reset "not for this site" preference
Whiteboard: feature=change c=tbd u=tbd p=0
Hi Juan, which original story can I link this change to?
Flags: needinfo?(jbecerra)
I don't think we're going to have management for this other than the big hammer of "Clear Private Data" in v1. 

For v2 I'm still thinking about how to split out site permissions (and whether a permission a site asks for like location is the same kind of thing as a permission Firefox asks for like password saving.)
Or put another way, this is really about v2 so it shouldn't block any v1 items. We can dump it in v2triage or something like that for now.
Blocks: metrov2planning
No longer blocks: metrov1it4
By the way, we already have the code written for "clear settings for this site" (which we shipped in XUL Fennec); it's just not exposed anywhere in the Metro UI.  So from an engineering perspective it would be very easy to restore that feature; we'd just need to know where to expose it.

The XUL Fennec code displays a "Clear Site Settings" button in the menu, alongside a list of settings that are remembered for the current site.  The button appears only on sites where the user has chosen some sort of persistent setting(s).
This one could hang from bug 831958 (access the options flyout) because that one contains the elements within and this would fit into it.
Flags: needinfo?(jbecerra)
Blocks: 831958
Related to Bug 831958 - Story - Access the Options Flyout
No longer blocks: 831958
Whiteboard: feature=change c=tbd u=tbd p=0
Bug 845484 covers the UI for resetting site settings/permissions.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 845484
You need to log in before you can comment on or make changes to this bug.