FxOS Bluetooth Pairing Dialog should take passwords longer than 4 numbers

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: qdot, Assigned: arthurcc)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18+ verified, b2g18-v1.0.1 verified)

Details

Attachments

(1 attachment)

Bluetooth pairing passwords can be longer than 4 numbers (on ubuntu, they're 6 numbers by default, though that can be reset), but the pairing dialog only allows for 4 numbers to be entered.
This problem can cause pairing failure if Bluetooth car kit only support Bluetooth 2.0 (without SSP pairing). PIN code is an ASCII string up to 16 characters in length. Specially it can fail many Ford SYNC car kit, because it automatically generate 6 digits. I think this issue must be fixed.
IOP impacts Ford, VW, Chevrolet (chevy) Bluetooth car kits. Many car kits use PIN code length more than 4 digits. PIN codes were generated by car kit itself so user cannot workaround.
blocking-b2g: --- → tef?
I thought we didn't care about car kits for v1.0.1?
(In reply to Kyle Machulis [:kmachulis] [:qdot] from comment #3)
> I thought we didn't care about car kits for v1.0.1?

Yeah, you're right. I think Shawn is just trying to make it work earlier. :)

This should not be too difficult to be fixed but it's quite important. I've talked with Evelyn and she will take over this.
Assignee: nobody → arthur.chen
(tef- cause we don't seem to care about cars for v1.0.1.  But if the patch is low risk and once landed on v1-train, please feel free to re-nom for uplift)
Assignee: arthur.chen → nobody
blocking-b2g: tef? → -
Assignee: nobody → arthur.chen
leo? for considering on v1.1
blocking-b2g: - → leo?
Created attachment 723320 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8561

Evelyn, please help review the change. Thanks!
Attachment #723320 - Flags: review?(ehung)
Evelyn, I set the font size of the input to 1.5rem so that the scroll bar does not appear. Please help review the change. Thanks.
Doesn't block certification or a 1.1. user story.  Please ask for approval to land once you have r+.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
Comment on attachment 723320 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8561

r=me. Thanks.
Attachment #723320 - Flags: review?(ehung) → review+
(In reply to Lucas Adamski [:ladamski] (plz needinfo) from comment #9)
> Doesn't block certification or a 1.1. user story.  Please ask for approval
> to land once you have r+.
By the rule here, can we land it on gaia-master first?
https://wiki.mozilla.org/Release_Management/B2G_Landing#All_other_landings_for_v1.x_.28updated_3.2F27.29
master: https://github.com/mozilla-b2g/gaia/commit/2bbafeb9f6308332c0d5a690535fa21bad8f7cef
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Nominate as tef+ since our partner reported the same problem in bug 870649. The problem is described very clear in comment 2 and bug 870649 comment 10. It would make us unable to pair with devices which has 2.0- bluetooth HW module.
blocking-b2g: - → tef?
In reply to Eric Chou [:ericchou] [:echou] from comment #13)
> Nominate as tef+ since our partner reported the same problem in bug 870649.
> The problem is described very clear in comment 2 and bug 870649 comment 10.
> It would make us unable to pair with devices which has 2.0- bluetooth HW
> module.

Forgot to mention that, the patch looks not too complicated, so it shouldn't affect v1-train/v1.0.1 too much. That's another good reason for pushing it into these stable codebases.

Updated

5 years ago
blocking-b2g: tef? → tef+
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
v1-train: https://github.com/mozilla-b2g/gaia/commit/8d98534aad61592058b003c7091b52145fec37b4
v1.0.1: https://github.com/mozilla-b2g/gaia/commit/f2ea904f2be5a491e7e86fdfcc4cb7ed18e57dfe
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed
Duplicate of this bug: 870649

Comment 17

5 years ago
This bug no longer reproduces, the password contains 6 digits now 

Environmental  Variables:
Unagi Build ID: 20130530070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/09ac1fd2959c
Gaia: 1cca9324d4444ad28c6fa99875e17abf7e8230be

Environmental  Variables:
Inari Build ID: 20130530070213
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/11b55d3ada71
Gaia: ac293ce59acc3bede083fad1b973794fa8bf0253
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.