If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Starting in turbo mode brings up 2 browser windows

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Ken Harris, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060703

After I run mozilla -turbo, starting Mozilla brings
up 2 browser windows.

Reproducible: Always
Steps to Reproduce:
1. Run "mozilla -turbo"
2. Run "mozilla" (or double-click a Mozilla icon)

Actual Results:  Two separate browser windows appear.  (But really fast!)

Expected Results:  Only one browser window should appear.

I have tried this on 2 Windows-2000 systems I thought were
identical (both with identical hardware, both systems installed
from the same Norton Ghost disk image).  It works fine on one,
it does this on the other.

Comment 1

17 years ago
What does it do if you don't run the preloader? There was a bug in some earlier
moz builds that opened 2 windows when you first ran it, but that got fixed a
while ago (0.8 i think, but I'm probably wrong :)
(Reporter)

Comment 2

17 years ago
If the preloader isn't run, it works fine -- one window.

Any tests you can think of to run on this computer I'll be glad
to do (but it's just a W2K workstation ... no development tools).

FWIW, one of the windows is about:blank, and the other is the
user's home page.

Comment 3

17 years ago
This happens on mine too, as described (on win98)
The empty window starts in diminished mode (not maximized), while the other
(home page one) starts maxamized as it should

Comment 4

17 years ago
->law
Assignee: asa → law
Component: Browser-General → XP Apps
(Assignee)

Comment 5

17 years ago
Please verify that this is still a problem in Jun 13 or later builds.  I fixed a
number of things related to this and it should no longer be a problem.
(Reporter)

Comment 6

17 years ago
Seems to work fine on 2001061504.

Comment 7

17 years ago
I haven't seen this since 0.9.1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.