Add warning if event loop is starved or events take a long time to get dispatched

RESOLVED WORKSFORME

Status

()

Core
Gecko Profiler
RESOLVED WORKSFORME
5 years ago
11 months ago

People

(Reporter: gwagner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
During debugging 848316 I noticed that it is really hard to find bugs that are caused by a busy main thread. 
We should add annotations when events are delayed for maybe > 100 msec or if there is no advance in the event loop.
I am scared that we have more bugs like this in gaia.

I don't know how hard this is to implement but it would be super useful!

Comment 1

5 years ago
FYI there are a few lag-measurements like https://bugzilla.mozilla.org/show_bug.cgi?id=710935, https://bugzilla.mozilla.org/show_bug.cgi?id=706916
We have event loop lag indicators in cleopatra these days. I think that's what was asked for in this bug.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.