speakeasy.net - [LAYER] Clicking on javascript links doesn't fill in the table

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P4
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Doug Shea, Unassigned)

Tracking

Details

(Whiteboard: [aok], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060703

On page http://www.speakeasy.net/rescompare, clicking on the the various service
options should fill in the table below. This does not happen, and nothing
appears in the table.

Reproducible: Always
Steps to Reproduce:
1. Go to the URL
2. Click on any of the service options
3. Notice how they don't appear on the table

Actual Results:  No results

Expected Results:  Service types should appear on the table for comparison.

Comment 1

17 years ago
This site uses layers; reassigning to Evangelism component. Layers
are no longer supported; see e.g. bug 50711 for further details -

Sample of the problem at this site: 


ns4 = (document.layers) ? true:false;
ie4 = (document.all) ? true:false;

function layerWrite (id,nestref,text) {
  if (ns4) {
    var lyr = (nestref) ? eval('document.'+nestref+'.document.'+id+'.document') 
: document.layers[id].document;
    lyr.open();
    lyr.write(text);
    lyr.close();
  }
  else if (ie4) document.all[id].innerHTML = text;
}
function colWrite(reqpckg) {
  var cnt=0;
  if (ccnt<=5) {
    id = "col"+ccnt+"Div";
    for (cnt=0; cnt<pckg.length; cnt++) {
      var pckgline = pckg[cnt].split("|");
      if (pckgline[0] == reqpckg) {
	++ccnt;
	var text='';
	var arraycnt=1;
	text += '<table border="0" cellpadding="0" cellspacing="1" width="90">';
	for (rcnt=0; rcnt<=14; rcnt++) {
	  if (rcnt==0) {
	    cellheight = 60;
	    cellcontent = '<b>' + pckgline[arraycnt] + ':</b><br>';
	    cellcontent += pckgline[3] + "<br>";
	    cellcontent += "[ <a 
href=\"javascript:StartPopup('http://www.speakeasy.net/main.php?page=empty&view=
empty&view=popup&page="+ pckgline[2] +"',560,200)\">Details</a> ]";
	    arraycnt= arraycnt+2;
	  }
	  else if (pckgline[arraycnt]) {
	    cellheight = 34;
	    cellcontent = pckgline[arraycnt];
	  }
	  else {
	    cellcontent = "&nbsp;";
	  }
	  text += '<tr><td><img src="/images/clearpixel.gif" height="' + 
cellheight + '"';
	  text += ' width="1"></td><td align="center" valign="middle">';
	  text += '<font face="Arial, Tahoma, Verdana, Helvetica, sans-serif" 
size="1">' + cellcontent + '</font></td></tr>';
	  arraycnt++;
	}
	text += '</table>';
	layerWrite(id,"tableDiv",text);
      }
    }  
  }
}
Assignee: rogerl → bclary
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Evangelism
Ever confirmed: true
OS: Windows 98 → All
QA Contact: pschwartau → zach
Summary: Clicking on javascript links doesn't fill in the table → [LAYER] Clicking on javascript links doesn't fill in the table

Updated

17 years ago
Priority: -- → P4

Updated

17 years ago
Summary: [LAYER] Clicking on javascript links doesn't fill in the table → speakeasy.net - [LAYER] Clicking on javascript links doesn't fill in the table

Comment 2

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Updated

17 years ago
Whiteboard: [aok]

Comment 3

17 years ago
Mass reassign of all tech-evangelism us general bugs assigned to bc to 
doron except bc's P1 bugs. You may search for this mass reassign (it is 
305 bugs) by searching for the keyword 'greeneggsandham'
Assignee: bclary → doronr

Comment 4

16 years ago
I think, i have a related problem with this:

o go on Url www.qip-net.de/frameset.htm 
o pulldown a menu by pointing with the mouse over it
o click on a item
o notice that the menu disappears, but nothing happens

-> This only happens on Mozilla under linux... under windows it works fine...

greets: Thomas Gruber, Germany

Comment 5

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 6

15 years ago
*** Bug 235297 has been marked as a duplicate of this bug. ***
seems to work now
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.