Unable to refresh local HTML file(s) if open in single tab due to the add-on DivX Plus Web Player HTML <video> 2.1.2.145

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Evan, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.152 Safari/537.22

Steps to reproduce:

Created a local HTML file in Notepad++ and tested it in three different browsers (Chrome, IE, Firefox).


Actual results:

I made changes to the HTML file and refreshed the browsers to see how it looked in each.  Only Chrome and IE actually refreshed the page.


Expected results:

Firefox should have refreshed the local HTML file, but didn't.  Shift + R, Shift + F5 does nothing.  It simply will not refresh the local HTML file.  I have to restart Firefox for the changes to be displayed.

This only happens if there is only one tab open (the one displaying the file).  If I open a new tab, I am then able to refresh the previous tab and see the changes applied.

Comment 1

5 years ago
Were you opening the local file (either using a file:// URL or via File -> Open) or visiting a local webserver (ie. an http:// URL)?
ctrl+f5 or shift+reload button are afaik the correct keyboard shortcuts.
(Reporter)

Comment 3

5 years ago
(In reply to Josh Matthews [:jdm] from comment #1)
> Were you opening the local file (either using a file:// URL or via File ->
> Open) or visiting a local webserver (ie. an http:// URL)?

I am opening it using Notepad++'s built in Run feature, however simply right-clicking on a local HTML file and opening it with Firefox causes the same issue.  It was not on a server.  When I open the HTML document from Notepad++, there is nothing in the URL bar (simply says 'Go to a website').  However opening a new tab will display the full address in the original tab (file:///C:/Users...).

(In reply to Matthias Versen [:Matti] from comment #2)
>ctrl+f5 or shift+reload button are afaik the correct keyboard shortcuts.

Neither of these shortcuts do anything when at the single tab.  They function when a new tab is opened/created.

Comment 4

5 years ago
Could you try with a fresh profile (don't import anything), please:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(evanvolm)
(Reporter)

Comment 5

5 years ago
(In reply to Loic from comment #4)
> Could you try with a fresh profile (don't import anything), please:
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles

Creating a new profile fixed the issue.  Going back to my original profile, I disabled my add-ons one by one and it turns out "DivX Plus Web Player HTML <video> 2.1.2.145" is the culprit.
Flags: needinfo?(evanvolm)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: General → Extension Compatibility
Product: Core → Firefox
Resolution: --- → WORKSFORME
Summary: Unable to refresh local HTML file(s) if open in single tab. → Unable to refresh local HTML file(s) if open in single tab due to the add-on DivX Plus Web Player HTML <video> 2.1.2.145
You need to log in before you can comment on or make changes to this bug.