Part files left over after cancelling a download.

RESOLVED DUPLICATE of bug 420355

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 420355
5 years ago
5 years ago

People

(Reporter: Donald Stufft, Unassigned)

Tracking

21 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130308 Firefox/21.0
Build ID: 20130308042013

Steps to reproduce:

Went to https://pypi.python.org/pypi/setix/0.8.1 and clicked on  setix-0.8.1.tar.gz under Downloads (http://d.stufft.io/image/2D2E073G2Z01) a dialog box will poped up asking if I wanted to Save file or Cancel (http://d.stufft.io/image/2E3Q2X0g2X05) and I clicked Cancel.


Actual results:

The file 'wl1OV9p2.exe.part' was left over in my Downloads folder.


Expected results:

The file 'wl1OV9p2.exe.part' should have been cleaned up by Firefox when the download was canceled.
Created attachment 723097 [details]
.part file that firefox is leaving behind.

I can reproduce this. I get a slightly more sane file name <random>.gz.part I've attached it for reference.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

5 years ago
It looks OSX-specific.
Component: Untriaged → Download Manager
Product: Firefox → Toolkit

Comment 3

5 years ago
This sounds like a duplicate of bug 420355, but I am not familiar with Mac OS.

Comment 4

5 years ago
I'm also having this same issue - FF21.0, OSX 10.8.3.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 420355
You need to log in before you can comment on or make changes to this bug.