Some of the field documentation has disappeared

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: ashughes, Assigned: dkl)

Tracking

(Blocks: 1 bug)

Production
x86_64
Linux

Details

Attachments

(1 attachment)

Since upgrading to Bugzilla 4.2 I no longer see some of the field documentation. For example, there's no longer any definitions of the various importance/severity levels.
https://bugzilla.mozilla.org/page.cgi?id=fields.html#importance
Blocks: 848218

Comment 1

4 years ago
From an upstream point of view, this is WONTFIX. The severities are customizable and can have different meanings to different groups, so each installation should customize the page based on their needs, if they bother enough. Note that this page is about the meaning of fields themselves, not about their values. I will let dkl or glob mark it as wontfix if they don't want to fix this for bmo.
Assignee: documentation → nobody
Component: Documentation → General
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production
(Assignee)

Comment 2

4 years ago
Created attachment 723322 [details] [diff] [review]
Patch to fix BMO custom help text not displaying properly (v1)

Stumped on this one so if you could take a look over me and see what I am missing. One fix I did was to add [% USE Bugzilla %] to the field-help-end.none.tmpl BMO hook. This allows the template to be used for page/fields.html.tmpl but this caused a recursion error due to display_value.

Bugzilla::Util::display_value calls Bugzilla::Util::template_var which loads global/field-descs.none.tmpl which calls bug/field-help.none.tmpl which calls BMO's bug/field-help-end.tmpl and so on.

Need to find a way for display_value to be allowed inside of field-descs.none.tmpl and its children or we could just remove the use of display_value entirely as I have done in this patch.

Let me know your thoughts.
dkl
Assignee: nobody → dkl
Status: NEW → ASSIGNED
Attachment #723322 - Flags: review?(glob)
Comment on attachment 723322 [details] [diff] [review]
Patch to fix BMO custom help text not displaying properly (v1)

r=glob

i'm happy dropping the display_value() calls.
Attachment #723322 - Flags: review?(glob) → review+
(Assignee)

Comment 4

4 years ago
Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.2         
modified extensions/BMO/template/en/default/hook/bug/field-help-end.none.tmpl
Committed revision 8646.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.