animateTransform tag which is the direct child of a svg tag does not animate the svg in Firefox

RESOLVED DUPLICATE of bug 849559

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 849559
5 years ago
5 years ago

People

(Reporter: Swarnendu, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

600 bytes, image/svg+xml
Details
(Reporter)

Description

5 years ago
Created attachment 723121 [details]
test1.svg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.160 Safari/537.22

Steps to reproduce:

<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"   "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg version="1.1" baseProfile="tiny" display="inherit" width="320" height="480" viewBox="0 0 320 480" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" xml:space="preserve">    
    <rect x="0" y="0" width="200" height="300" fill="#f0f"></rect>    
    <animateTransform additive="sum" attributeName="transform" begin="2" dur="4" fill="freeze" keyTimes="0;.5;1" type="translate" values="0 0;50 50;0 0"/>   
</svg>


Actual results:

Animation not working


Expected results:

Rect should move from (0,0) to (50,50) then come back to (0,0)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 849559
You need to log in before you can comment on or make changes to this bug.