Closed Bug 849573 Opened 8 years ago Closed 8 years ago

Regression: GL graphic glitches in tab menu - LG Nexus 4

Categories

(Firefox for Android :: Toolbar, defect)

22 Branch
ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 22
Tracking Status
firefox21 --- unaffected
firefox22 --- fixed
fennec 22+ ---

People

(Reporter: aaronmt, Assigned: cwiiis)

References

Details

(Keywords: regression, reproducible)

Attachments

(2 files)

Regression from bug 716403; steps: open the tab menu

See screenshot

--
LG Nexus 4 (Android 4.2.2)
Nightly (03/09)
I've tried this on the most recent Nightly on a Nexus 4 wih 4.2.2 and I can't reproduce. Do you literally just open the tabs tray and that's what happens? I've tried opening it from all orientations, with a page or the home screen loaded and everything is fine (well, except for the SurfaceView not scrolling in the landscape-right orientation, but whatever...)
Open and close the tab tray in portrait rapidly on about:home
In my case I had content open, using 03.11's build now yielding the same problem when the tray tray rolls back up.
Oh, I see, was able to reproduce (though it's very hard to catch :)) - I'll defer to Lucas/Sriram on this as it doesn't/shouldn't involve Gecko...
leaving as a tracking nom until we get a regression window
Assignee: nobody → lucasr.at.mozilla
(In reply to Brad Lassey [:blassey] from comment #7)
> leaving as a tracking nom until we get a regression window

Bug 716403.
Assignee: lucasr.at.mozilla → nobody
Assignee: nobody → lucasr.at.mozilla
Duplicate of this bug: 848317
bug 848317 (duped to this) is much easier to reproduce. Just copy the URL in the url bar using the action bar button; as the action bar dismisses you will see the graphical glitch.
I find dismissing the tab menu just as easy. Unrelated, I also see this on about:home https://bug846772.bugzilla.mozilla.org/attachment.cgi?id=720039 on dismissal
tracking-fennec: ? → 22+
Blocks: 850724
No longer blocks: 850724
I don't think we need a regression window, this was caused by bug 716403 and would likely be fixed by not using the LinearLayout spacer. I thought we'd talked about this?
After discussing this on IRC, we suspect bug 716403 might not be the offender here. Requesting a regression window.
Summary: Regression: GL graphic glitches on navigation bar - LG Nexus 4 → Regression: GL graphic glitches in tab menu - LG Nexus 4
Video I recorded earlier http://www.youtube.com/watch?v=f83KB67oZt4
If I'm very quick, I can get a black area to appear similar to the video Aaron recorded on my RAZRi - It seems that cancelling the animation before it completes runs the whole animation backwards (as opposed to just the part that's necessary), but there's nothing rendered in the surface for it to animate and it just ends up with whatever junk was in the texture (I guess).

It seems like this could be fixed by cancelling the animation with the immediate flag that I added. I'm going to see if this is easy and cook up a patch.
Does fix it for me :) Patch incoming.
Assignee: lucasr.at.mozilla → chrislord.net
Status: NEW → ASSIGNED
Comment on attachment 727423 [details] [diff] [review]
Handle interrupted tabs tray animation more gracefully

Review of attachment 727423 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me.
Attachment #727423 - Flags: review?(sriram) → review+
Thanks for your impressively fast review, unfortunately I couldn't capitalise on it because inbound was closed and I had to sleep :( Still, pushed now: https://hg.mozilla.org/integration/mozilla-inbound/rev/13efcaa536a7
Duplicate of this bug: 850923
https://hg.mozilla.org/mozilla-central/rev/13efcaa536a7
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Version: Trunk → Firefox 22
That did it, nice work
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.