Firefox 19.0.2 doesn't open PDFs with internal viewer on Ubuntu 12.04 x64

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: bedfordstuyvesant, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 723191 [details]
FF_wont_open_PDF.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307122903

Steps to reproduce:

I wanna open a PDF in a new tab by using the internal Firefox - PDF-viewer. As OS I'm using UBUNTU 12.04 x64.


Actual results:

Firefox opened the messagebox where I've the choice to choose an application to open the file or download it.
And under Settings > Applications there is a questionmark at the point „Portable Document Format (PDF)“


Expected results:

Before the last update Firefox used the internal PDF-viewer to open these filetype - in background in a new tab (middleclick) or in foregound (leftclick). But since update to 19.0.2 I can only use the OS - internal PDF-viewer (evince) or save the file directly - but I wanna see it in Firefox!
Even when I take the way „choose an application“ and I give the path to Firefox it doesn't work...

Comment 1

6 years ago
Did you follow the FAQ?
https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them
Flags: needinfo?(bedfordstuyvesant)
(Reporter)

Comment 2

6 years ago
I've found a way to make the internal viewer work again properly:
At first I've tried all the suggestions on the https://support.mozilla.org - pages:
- deactivating all the security-plugins, removing „mimetypes.rdf“ & „pluginreg.dat“, checking the about:config & about:plugins... but nothing works.
At least I tried this:
„sudo apt-get install --reinstall firefox“ → and now the defect is eliminated and FF opens the PDF-Files in it's own internal viewer, in foreground and in background using a new tab!
Flags: needinfo?(bedfordstuyvesant)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.