some comments fail with "Service Unavailable"

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Aj, Unassigned)

Tracking

(Blocks: 1 bug)

Production
x86_64
FreeBSD

Details

(Reporter)

Description

5 years ago
:wsm is experiencing issues submitting certain bugs (ie not all submissions fail).
Using this one as a test base and for a way to reference the issue.

Comment 1

5 years ago
Commit attempts for some bugs fail with in "Service Unavailable".
Fails occur on multiple attempts, multiple browsers between 10:16:38 and 10:18:11 for
- bug 322337 changing summary
- bug 653450 changing status and resolution
I logged out, and logged back in - no change.

And yet Some commits are successful.
- bug 849651 cc:
- bug 841307 component change
- bug 826906 component change


I am not logged in via persona (bug 849518)

Comment 2

5 years ago
comment 1 posting successful via wsm0 account.
whereas, posting via vseerror account fails
(Reporter)

Updated

5 years ago
Blocks: 848218

Comment 3

5 years ago
aj concludes my posting problem is somehow related to my vseerror BMO account.  Which is odd, because I use my account many times since the BMO 4.2.5 update ... no problems until 4:30pm EST today, Sunday

Comment 4

5 years ago
test
Summary: User issue → some commits fail with "Service Unavailable"

Comment 5

5 years ago
for grins, I granted wsm0 editbugs and canconfirm priveleges and I was just able to post the changes. So, my problem with vseerror account is not strictly related to having those priveleges.

Updated

5 years ago
Severity: normal → major
i suspect one of the webheads was having transient problems, resulting in the errors you're seeing.  i don't think it's related to your vseerror@lehigh.edu account.

there have been memory consumption issues reported across the webheads, which we're tracking down, so it's possible you've been hitting this.

i'll do some more investigation and report back if i find anything of interest.
Summary: some commits fail with "Service Unavailable" → some comments fail with "Service Unavailable"

Comment 7

5 years ago
Hello.

I've been trying to vote for a few bugs since March 10th 11:30 PST and I always get either "Service Unavailable" or "Internal Server Error". I'm logged in via my regular Bugzilla account, not Persona.

Comment 8

5 years ago
test from work PC
if you encounter a 'service unavailable' error, please note the the exact time (including timezone) on this bug.
(In reply to wsm0 from comment #1)
> Fails occur on multiple attempts, multiple browsers between 10:16:38 and
> 10:18:11

wayne told me on irc these are for sunday 3rd, and the times are in EST

Comment 11

5 years ago
(In reply to Byron Jones ‹:glob› from comment #10)
> (In reply to wsm0 from comment #1)
> > Fails occur on multiple attempts, multiple browsers between 10:16:38 and
> > 10:18:11
> 
> wayne told me on irc these are for sunday 3rd, and the times are in EST

sunday the tenth :)

Updated

5 years ago
Duplicate of this bug: 851267
i haven't had any further reports of this happening, closing bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 14

5 years ago
Now that I am able to comment, here is a copy of some of my emails:
* April 5th:
"When I try to save changes on comments, crash signatures or file a new bug, I get Service Unavailable at least up to 8H UTC the next day. Editing only tracking flags or keywords seems OK.
It seems to show up again when I change many bugs in a row.
It started showing up at the end of April 3rd."

* April 5th:
"I added a comment in https://bugzilla.mozilla.org/show_bug.cgi?id=786153 and get Service Unavailable at 13:00:30 UTC
I added a crash signature in https://bugzilla.mozilla.org/show_bug.cgi?id=848913 and get Service Unavailable at 13:02:25 UTC
I submitted a new bug and get Service Unavailable at 13:04:08 UTC"

* April 6th:
"It was back to normal around 17H UTC.
I think I found the culprit, https://bugzilla.mozilla.org/show_bug.cgi?id=848913, because after having added a crash signature to it a few minutes ago, I got again Service Unavailable for all bugs I comment or add a crash signature. I now remember that it started this morning and yesterday evening with the same operation."
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
an errant setting on bugzilla.mozilla.org's load balancer appears to have been the cause of the "service unavailable" errors.  this setting has been changed, so we should be good now.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.