all unit tests failed since travis switched to 64bit VM

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: yurenju, Assigned: yurenju)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

all unit tests failed since travis got 64bit VM
https://travis-ci.org/mozilla-b2g/gaia/pull_requests

we need to download 64bit firefox instead of 32bit.
Comment on attachment 723356 [details]
PR: https://github.com/mozilla-b2g/gaia/pull/8563

r=me. I hate the build is failed message so I steal the review.

BTW what's the sms fix here? If it's not relevant to this issue, I recommend to put it in another bug.
Attachment #723356 - Flags: review?(timdream) → review+
Sure, merged without fixing sms unit test.
https://github.com/mozilla-b2g/gaia/commit/b398be093a4e2d62326023764d6eea1faf2acb49
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 851534
Comment on attachment 723356 [details]
PR: https://github.com/mozilla-b2g/gaia/pull/8563

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: unit tests failed on travis for v1-train & v1.0.1
Testing completed:
Risk to taking this patch (and alternatives if risky): None
String or UUID changes made by this patch:
Attachment #723356 - Flags: approval-gaia-v1?(21)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
reopen since we have same problem on v1-train & v1.0.1
Correct flags.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → affected
Resolution: --- → FIXED
Who could approval-gaia-v1? when Vivien is on vacation?
I might as well as raise this issue to tef+, it will be faster than approval :-/
blocking-b2g: --- → leo?
blocking-b2g: leo? → tef?
just land it with a=npotb, right ?
Hey, I'll land it myself :)
a=npotb
v1-train: 8e9008e80876d4769a085ed0e0c3fe8350fe3036
v1.0.1: a6a0a120e45f7244341315e1b478f0736a09cd6a
blocking-b2g: tef? → ---
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed
Attachment #723356 - Flags: approval-gaia-v1?(21)
You need to log in before you can comment on or make changes to this bug.