Helper applications not imported from Netscape profile

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
18 years ago
3 years ago

People

(Reporter: craig, Unassigned)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When Mozilla imports it's defaults from Netscape, it doesn't install the list of
helper applications, which results in unique browser behaviour (image/pjpeg mime
type doesn't have an application associated with it). Only MIME type with
default behaviour is text/html.

Comment 1

18 years ago
Dear Craig, could you please retest it with a newer build? According to bug
writing guidelines it's always a great help to include build ID, etc.

Comment 2

18 years ago
I'm having exactly the same issue with the Mac version.  It would be really
great to have an Import option in the File menu that could be used to import
Helper Apps from existing programs.  Adding one Helper App at a time is tedious
and prone to error.
-> Profile Migration.

This sound like a request for an enhacement so marking it as such.
Assignee: rickg → racham
Severity: normal → enhancement
Component: Viewer App → Profile Migration
OS: Linux → All
QA Contact: rickg → gbush
Hardware: PC → All
Summary: Helper applications not imported from Netscape profile → [RFE] Helper applications not imported from Netscape profile

Comment 4

18 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
Mozilla will not properly read file associations and launch helper app when
launcing a playlist from mp3.com. I have attempted to DL and reinstall the
helper app directly from netscape via the plug-ins link with the same result Mz
seems to be unable to launch the app. [note the plug-in log does show this
helper app was successfully installed]

Strangly when clicking a "single" play [rather than a playlist] from mp3.com, Mz
will go through the process of spawning the helper. I will test it on a
different machine later today to see if i have the same behavior on a "clean"
install [i.e. without a profile transfer]

Using the common MP3Fix program [used to fix the file assocations/mime types for
IE or NS] has no effect on the behavior.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3) Gecko/20010801

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 6

17 years ago
On linux 1.0rc2, the user's private .mailcap and .mime.types files are correctly
imported.  That is, the right helper apps launch.  The global mailcap, 
if installed in /etc, is imported as well.

However, the imported .mailcap and .mime.types don't show
up in Edit Menu -> Preferences -> Navigator -> Helper
Applications.  (which I assume is the point of this bug,
and why it's classified as RFE.)

Updated

16 years ago
Summary: [RFE] Helper applications not imported from Netscape profile → Helper applications not imported from Netscape profile
mass re-assign.
Assignee: racham → sspitzer
Status: ASSIGNED → NEW
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
QA Contact: agracebush → profile-migration
Netscape is dead and I don't think a profile migration of helper apps makes sense today
marking wontfix
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.