Unsupported URL /generic/seller/ ()

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kumar, Assigned: Andy McKay)

Tracking

x86
Mac OS X
Points:
---

Details

(Whiteboard: p=1)

HttpServerError: Server Error 500: https://payments-dev.allizom.org/generic/seller/
Content: {"error_code": "ValueError", "error_data": {}, "error_message": "Unsupported URL /generic/seller/ ()."}

http://sentry.dmz.phx1.mozilla.com/amo-ops/marketplace-dev-webpay/group/12266/

STR:
- select Private Yacht on dev
- click purchase

As webpay opens, we hit this error
Blocks: 775802
Priority: -- → P1
I don't get why this results in Unsupported URL but it seems like the root cause in Solitude is Ravent trying to do this:

json.dumps(sanitise(json.loads(http['data'])))

while http['data'] is None.

Solitude traceback: http://sentry.dmz.phx1.mozilla.com/amo-ops/marketplace-dev-webpay/group/12266/
(Assignee)

Updated

5 years ago
Assignee: nobody → amckay
Priority: P1 → P2
Whiteboard: p=1
(Assignee)

Comment 2

5 years ago
I think this is fixed, missing SITE_URL, will need to roll out stage and prod config changes if this works.
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla/solitude/commit/db50a8
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.