Build error: --with-system-png requested but no working libpng found

RESOLVED INVALID

Status

Firefox for Android Graveyard
General
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Atanas, Assigned: Glenn Randers-Pehrson)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130218165301

Steps to reproduce:

tried to compile fennec with the following flag:
--with-system-png


Actual results:

configure: error: --with-system-png requested but no working libpng found
*** Fix above errors and then restart with               "make -f client.mk build"
make[2]: *** [configure] Error 1


Expected results:

I tried to pass --with-system-bz2; --with-system-jpeg; --with-system-zlib and checking was successful for them so I guess it should be successful for png too because I have libpng12-dev installed

Updated

5 years ago
Component: General → General
OS: Linux → Android
Product: Fennec → Firefox for Android
Hardware: x86 → ARM
Summary: no working libpng found → Build error: --with-system-png requested but no working libpng found
I'm fairly sure we require a more recent version of libpng than 12 http://dxr.mozilla.org/mozilla-central/configure.in#l4118
I don't really know, Joe?
(Reporter)

Updated

5 years ago
Component: General → General
OS: Android → Maemo
Product: Firefox for Android → Fennec
We not only require libpng version 1.5.13 or newer, we also require a system libpng compiled with APNG support. The precise problem you're finding will be listed in configure's output.
(Assignee)

Comment 4

5 years ago
You have to either upgrade your libpng to 1.5.13 or later, or just don't attempt to use the system libpng.  The latter is probably the simpler approach.  Taking bug and resolving it as INVALID since it's not a moz bug.
Assignee: nobody → glennrp+bmo
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.