Closed Bug 850110 Opened 8 years ago Closed 8 years ago

Download server IP address is sometimes reported as a single digit.

Categories

(Firefox :: Installer, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 22
Tracking Status
firefox20 --- verified
firefox21 --- verified
firefox22 --- verified
firefox23 --- unaffected

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

Details

(Whiteboard: [stub=])

Attachments

(2 files)

The lpvStatusInformation doc for wininet status callback INTERNET_STATUS_NAME_RESOLVED states it is a PCTSTR but it is usually a PCSTR (also note the comment to that affect).

http://msdn.microsoft.com/en-us/library/windows/desktop/aa385121%28v=vs.85%29.aspx
Approximately 11% of the time we are getting a single digit for the IP Address. I suspect that in some cases it is returning a PCTSTR.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #723789 - Flags: review?(netzen)
Attachment #723789 - Flags: review?(netzen) → review+
compiled plugin for checkin
Attachment #725844 - Flags: review+
Whiteboard: [stub=]
Comment on attachment 725844 [details] [diff] [review]
patch InetBgDl.dll NSIS plugin

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 811573
User impact if declined: None. This impacts metrics reporting and our ability to troubleshoot the stub installer.
Testing completed (on m-c, etc.): This has been on nightly for a day and the stub ping data has not had a single report with only a single digit for the download server IP address since the nightly build was built vs. approximately 14% of the pings having a single digit for the download server IP address. There have been no anomalies seen in the ping data and no bug reports.
Risk to taking this patch (and alternatives if risky): It is a fairly simple fix with little risk.
String or UUID changes made by this patch: None
Attachment #725844 - Flags: approval-mozilla-beta?
Attachment #725844 - Flags: approval-mozilla-aurora?
Comment on attachment 725844 [details] [diff] [review]
patch InetBgDl.dll NSIS plugin

We can take this right now on our second-to-last beta, please uplift asap.
Attachment #725844 - Flags: approval-mozilla-beta?
Attachment #725844 - Flags: approval-mozilla-beta+
Attachment #725844 - Flags: approval-mozilla-aurora?
Attachment #725844 - Flags: approval-mozilla-aurora+
QA, there is no way for you to verify this. I will examine the stub ping data over the next several days and report back whether this has been fixed or not. Thanks!
For the nightly channel

    Date   | Total |  Invalid IP | Percent
-----------+-------+-------------+--------
2013-03-06 |  228  |      5      |  2.19%
2013-03-07 |  428  |     11      |  2.57%
2013-03-08 |  364  |     18      |  4.95%
2013-03-09 |  392  |     16      |  4.08%
2013-03-10 |  316  |      7      |  2.22%
2013-03-11 |  369  |     12      |  3.25%
2013-03-12 |  363  |     12      |  3.31%
2013-03-13 |  342  |     13      |  3.80%
2013-03-14 |  313  |     11      |  3.51%
2013-03-15 |  263  |      6      |  2.28%
2013-03-16 |  365  |     10      |  2.74%
2013-03-17 |  329  |      9      |  2.74%
2013-03-18 |  371  |      3      |  0.81% <--- patch included in the nightly stub build
2013-03-19 |  384  |      0      |  0.00%

Total = Total pings
Invalid IP = single digit number for download server IP Address
Percent = percentage of Invalid IP pings out of the Total pings
For the nightly channel

    Date   | Total |  Invalid IP | Percent
-----------+-------+-------------+--------
2013-03-06 |  228  |      5      |  2.19%
2013-03-07 |  428  |     11      |  2.57%
2013-03-08 |  364  |     18      |  4.95%
2013-03-09 |  392  |     16      |  4.08%
2013-03-10 |  316  |      7      |  2.22%
2013-03-11 |  369  |     12      |  3.25%
2013-03-12 |  363  |     12      |  3.31%
2013-03-13 |  342  |     13      |  3.80%
2013-03-14 |  313  |     11      |  3.51%
2013-03-15 |  263  |      6      |  2.28%
2013-03-16 |  365  |     10      |  2.74%
2013-03-17 |  329  |      9      |  2.74%
2013-03-18 |  371  |      3      |  0.81% <--- patch included in the nightly stub build
2013-03-19 |  384  |      0      |  0.00%
2013-03-20 |  346  |      1      |  0.29%


For the aurora channel

    Date   | Total |  Invalid IP | Percent
-----------+-------+-------------+--------
2013-03-07 |  729  |    108      | 14.81%
2013-03-08 | 1160  |    140      | 12.07%
2013-03-09 | 1090  |    169      | 15.50%
2013-03-10 |  864  |    137      | 15.86%
2013-03-11 | 1150  |    139      | 12.09%
2013-03-12 |  971  |    150      | 15.45%
2013-03-13 | 1020  |    170      | 16.67%
2013-03-14 | 1021  |    171      | 16.75%
2013-03-15 |  968  |    109      | 11.26%
2013-03-16 |  869  |    114      | 13.12%
2013-03-17 |  878  |    110      | 12.53%
2013-03-18 |  914  |    124      | 13.57%
2013-03-19 |  960  |    147      | 15.31%
2013-03-20 |  976  |     86      |  8.81% <--- patch included in the aurora stub build

Total = Total pings
Invalid IP = single digit number for download server IP Address
Percent = percentage of Invalid IP pings out of the Total pings

Note: the beta stub being provided to download is the one from prior to this fix so it doesn't reflect it yet.

With the nightly data improving so significantly I am changing this to verified. I'll verify it on aurora before changing status-firefox21 to verified.
Status: RESOLVED → VERIFIED
With the following improvements I am satisfied that this bug is fixed. There might be some edgecases where this will happen which I am fine with as long as it isn't around 14% as it was previously on the aurora channel. I suspect that some of the remaining cases are due to people using a previously downloaded stub that doesn't contain the fix.

For the nightly channel

    Date   | Total |  Invalid IP | Percent
-----------+-------+-------------+--------
2013-03-06 |  228  |      5      |  2.19%
2013-03-07 |  428  |     11      |  2.57%
2013-03-08 |  364  |     18      |  4.95%
2013-03-09 |  392  |     16      |  4.08%
2013-03-10 |  316  |      7      |  2.22%
2013-03-11 |  369  |     12      |  3.25%
2013-03-12 |  363  |     12      |  3.31%
2013-03-13 |  342  |     13      |  3.80%
2013-03-14 |  313  |     11      |  3.51%
2013-03-15 |  263  |      6      |  2.28%
2013-03-16 |  365  |     10      |  2.74%
2013-03-17 |  329  |      9      |  2.74%
2013-03-18 |  371  |      3      |  0.81% <--- patch included in the nightly stub build
2013-03-19 |  384  |      0      |  0.00%
2013-03-20 |  346  |      1      |  0.29%
2013-03-21 |  411  |      0      |  0.00%


For the aurora channel

    Date   | Total |  Invalid IP | Percent
-----------+-------+-------------+--------
2013-03-07 |  729  |    108      | 14.81%
2013-03-08 | 1160  |    140      | 12.07%
2013-03-09 | 1090  |    169      | 15.50%
2013-03-10 |  864  |    137      | 15.86%
2013-03-11 | 1150  |    139      | 12.09%
2013-03-12 |  971  |    150      | 15.45%
2013-03-13 | 1020  |    170      | 16.67%
2013-03-14 | 1021  |    171      | 16.75%
2013-03-15 |  968  |    109      | 11.26%
2013-03-16 |  869  |    114      | 13.12%
2013-03-17 |  878  |    110      | 12.53%
2013-03-18 |  914  |    124      | 13.57%
2013-03-19 |  960  |    147      | 15.31%
2013-03-20 |  976  |     86      |  8.81% <--- patch included in the aurora stub build
2013-03-21 |  946  |     15      |  1.59%

Total = Total pings
Invalid IP = single digit number for download server IP Address
Percent = percentage of Invalid IP pings out of the Total pings
This looks 100% fixed or at least as close as can be... there has not been a single report out of 13032 records since 2013-03-27
Target Milestone: --- → Firefox 22
You need to log in before you can comment on or make changes to this bug.