firefox beta crash on galaxy gio

RESOLVED INCOMPLETE

Status

()

Firefox for Android
General
--
critical
RESOLVED INCOMPLETE
5 years ago
2 years ago

People

(Reporter: M. Khayron, Unassigned)

Tracking

({crash, stackwanted})

20 Branch
ARM
Android
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Opera/9.80 (Android 2.3.6; Linux; Opera Mobi/ADR-1301071820) Presto/2.11.355 Version/12.10

Steps to reproduce:

open the app (firefox) and i get my galaxy gio can't oporated n must reboot


Actual results:

when trying firefox beta (20) or firefox for android (19) in my galaxy gio, my phone can't operated (crash) and must hard reboot by press home+power for long time. please fix this issue. thank you
(Reporter)

Updated

5 years ago
Severity: normal → critical
Keywords: crash, crashreportid
OS: Linux → Android
Hardware: Other → ARM

Comment 1

5 years ago
Firefox 20 for Android requires at least 384MB of RAM (see https://wiki.mozilla.org/Mobile/Fx20_PRD#System_Requirements) while your phone has only 150MB of RAM (see http://www.samsung.com/galaxyace/gio_techspec.html).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: crashreportid
Resolution: --- → INVALID
Whiteboard: [native-crash]
Scoob, that's internal storage. 

The Samsung Gio, which I own, has 384MB ~ 290 usable MB of RAM.

Can you capture and attach a log-cat? Please install aLogcat from the Google Play Store. Start aLogcat, clear the logs, start Firefox, go back to aLogcat and save the log. Attach that saved log to this bug report.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(coys.jrux)
Resolution: INVALID → ---

Comment 3

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #2)
> The Samsung Gio, which I own, has 384MB ~ 290 usable MB of RAM.
I've also checked http://pdadb.net/index.php?m=specs&id=2751&view=1&c=samsung_gt-s5660_galaxy_gio before answering and nothing mentioned the size of RAM.
Is the RAM size equal to 512-150=362MB? It's still lower than 384MB.
Keywords: stackwanted
(Reporter)

Comment 4

5 years ago
hi Aaron,
i'm sorry i can't provide the log because every start the firefox, my phone hang (only power button can operate for lock screen) and the display not respond. i have to reboot my phone by press home+power button for a long time to get normal function. what is another way to trace the error beside the log so i can provide it for you?
Flags: needinfo?(coys.jrux)
You can also capture the logs after a reboot, information might still be available.

You can also capture output straight from log-cat using the adb utility found with an installation of the Android SDK Tools and Android SDK Platform Tools in the Android SDK (http://developer.android.com/tools/sdk/ndk/index.html)

As it stands now there's nothing actionable in this bug, so it is incomplete.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

5 years ago
Created attachment 724305 [details]
log phone when start firefox

hi Aaron,
here i'm attach log of my phone use alogcat. this log is saved after reboot the phone.
You need to log in before you can comment on or make changes to this bug.