CSS Inspector returns some incorrect line-numbers

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 months ago

People

(Reporter: cake, Unassigned)

Tracking

19 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Inspect the styles associated with an element.

For example, view the following URL and then inspect the UL element: http://www.brothercake.com/Ref/line-numbers.html


Actual results:

Some rules were returned with the wrong line number. When the rule has only one selector, and that is a simple element selector, the returned line number is 1 greater than the actual line number. 

This doesn't happen for all such rules, but it does happen for most of them. I thought it might be related to the formatting of the rule, or the types of properties it contains, but I have not been able to lock it down to specific circumstances.

Testing within an extension environment, I discovered that the getRuleLine method of inIDOMUtils is returning these incorrect values.


Expected results:

The line number should match the start of the rule.
Component: Untriaged → Developer Tools: Inspector

Comment 1

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0

Steps to reproduce:

Open http://www.brothercake.com/Ref/line-numbers.html
Launch Inspector and inspect the <ul> element


Actual results:

Line number showed and actual match


Expected results:

In the Inspector, the reference displayed in every rule has the actual line number where the rule was defined in stylesheet.


Comment:


This bug is for an old version of firefox, I could not reproduce it.
(Reporter)

Comment 2

4 years ago
Agreed, I can no longer reproduce it either.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.