Black icon for Firefox Metro when in edge-swipe view

RESOLVED WORKSFORME

Status

Firefox for Metro
Browser
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: virgil, Unassigned)

Tracking

22 Branch
x86_64
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 723970 [details]
Firefox metro thumbnail in swipe edge view

Mozilla/5.0 (Windows NT 6.2; rv:22.0) Gecko/20130311 Firefox/22.0

Not sure how it got that way, but the Firefox icon in edge-swipe view (it might have a different name) is now a black rectangular.

1. Hover over left upper corner.
2. Hover and scroll down.
Actual result: Black icon instead of the regular Firefox thumbnail.

This only happens on one machine. Couldn't reproduce on the other Windows 8 machine - the thumbnail is displayed as expected.

I should be able to investigate this tomorrow more, but if anyone has any pointers on what I should look for, that would help. Figured this report might be of help as is.

Updated

5 years ago
Blocks: 841214

Comment 1

5 years ago
I'm not able to reproduce this with the latest nightly m-c build. Is it still happening for you?
(Reporter)

Comment 2

5 years ago
I can still this. 

Tried:
-clean profile
-removed all profiles
-reinstalled latest Nightly (normal 32 bit installer)

Windows on 64 bits. Administrator account. 
I'm not sure what else could I try. Other apps are displayed normally. The only noticeable difference towards the other Windows 8 machine is the card - AMD.
Hardware: x86 → x86_64

Comment 3

5 years ago
Is this is with metrofx suspended in the background? Or are you expecting the desktop browser to show up in the thumbnail view?
(Reporter)

Comment 4

5 years ago
In reply to Jim Mathies [:jimm] from comment #3)
> Is this is with metrofx suspended in the background? Or are you expecting
> the desktop browser to show up in the thumbnail view?

Metrofx running in the background with or without desktop browser open. 

I would expect to see the thumbnail regardless of desktop browser running or not. This is the normal behavior for other apps and for Metro FX on other Win 8 machines.

Tried using Win 8 32 bits on the same machine - no problems in displaying the thumbnail in edge-swap. 

On the machine where I can reproduce -64 bit version- the splash screen logo is black at startup - thinking this might have something to do with the black thumbnail?
(Reporter)

Comment 5

5 years ago
Again, this issue only occurs on one 64 bit machine - couldn't reproduce on other machines. If nobody else has a clue, I think we can close this for the moment and keep an eye on for any other symptoms.
Just so I understand the problem fully, it is always black right? You can never get it to show a preview of the app on that machine correct?
(Reporter)

Comment 7

5 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #6)
> Just so I understand the problem fully, it is always black right? You can
> never get it to show a preview of the app on that machine correct?

Yes. Clean profile, re-install - no other result.
If we hear back about more people with this problem let's promote it back to v1 with reports of specific hardware and we'll need to get that hardware to a dev.
Blocks: 842686
No longer blocks: 841214

Comment 9

5 years ago
I wonder if this is a graphics card issue.  Virgil, what is your graphics setup like?
(Reporter)

Comment 10

5 years ago
(In reply to Asa Dotzler [:asa] from comment #9)
> I wonder if this is a graphics card issue.  Virgil, what is your graphics
> setup like?

This is:
ATI Radeon HD 5450
Driver Version 4.2.11903 
IDATI Technologies Inc.
WebGL RendererATI Technologies Inc. -- ATI Radeon HD 5450

This was solved with the last patch of Windows Updates (Windows issue?), so closing - should be ok now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
No longer blocks: 842686
You need to log in before you can comment on or make changes to this bug.