Update Funnelcake Fallback Page URL

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: bensternthal, Assigned: pmac)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Adding implementation notes here.

According to Jakem we need to update the installer-help page so that the link for 

firefox-20.0b4 

is changed to:

firefox-20.0b4-funnelcake20

Timing wise we need to know:
- When can this be tested?
- When can this go live
- When if ever should this be reverted back?
(Reporter)

Updated

6 years ago
Flags: needinfo?(akeybl)

Comment 1

6 years ago
This should go live today or tomorrow... pending a sign-off from QA/Metrics/Rel-Eng. It loosely needs to happen in concert with an IT change to support the same A/B funnelcake test.

Reversion would be "whenever Metrics tells us to stop the A/B funnelcake test", which will be approximately 9 days after starting.


There are also 2 alternative implementations:

1) Change to point to firefox-beta-latest ... bouncer will internally redirect this to firefox-20.0b4-funnelcake20. Problem here is what if someone finds this fallback page but isn't downloading for win/en-US... will firefox-beta-latest still work right? I don't know if that product knows about other platforms and locales, or just win/en-US because that's all stub installer needs. catlee/bhearsum/nthomas might have a better idea. In any case this seems likely to be insignificantly different from hard-coding the -funnelcake20 product directly.

2) Change nothing on the fallback page- attempt to detect and rewrite these on bouncer, based on the Referer header. This is how we've done this in the past, but as you can imagine it's not foolproof. It complicates the ruleset that IT has to manage, and we can't always guarantee that this header will be present to trigger off of. It "mostly" works.
I don't like #2 much, but I like it better than adding and removing stuff from bedrock on a schedule. This is a tough one. It'd be really nice if the stub could send them to this url w/ a query string we could use to decide which build to give them. For example:

http://www.mozilla.org/en-US/firefox/installer-help/?fc=20

This would give us the ability to just leave this up there for future use. I'd really, really rather not add code that's scheduled to be removed if we can help it.
Or even better would be if we can just always use `product=firefox(-beta|-aurora)?-latest` and let bouncer do what it will.

Comment 4

6 years ago
Comment 2 is a feature request for :rstrong / :akeybl, and there's probably no chance of doing that in time for this test.

Comment 3 is a feature request / confirmation for Rel-Eng (catlee)... I don't know how feasible that is, or indeed if it's already done. The primary concern as I see it would be if "firefox(-beta|-aurora)?-latest" will work with non win/en-US builds. We could probably get away with it for this test even if it only works with win/en-US, but that would make it unsuitable as a general solution... this is a publicly accessible page, so we cannot guarantee that all traffic to it will have come from stub installer.
Yeah... I would like to find out the exact state of the *-latest products. It would be super nice if that Just Works(TM).
What we'll probably have to end up doing then is to alter the way our download buttons work by providing an option to override the download version per platform. So the buttons could show firefox-latest for the windows button, and the normal version for mac and linux. Then we can just leave this code in but turn the option off when it's time.
(Reporter)

Comment 7

6 years ago
Do we need anyone to sign-off on the above/do we need any additional info or Pmac are you good to go on this task?
(Reporter)

Comment 8

6 years ago
We have not heard any feedback on this. I will email out a reminder, if we do not hear anything in an hour or so we will move forward with:

https://bugzilla.mozilla.org/show_bug.cgi?id=850295#c6

Comment 9

6 years ago
comment 6 is fine with me. :)
(Reporter)

Comment 10

6 years ago
Thanks jake!

Pmac I have not heard feedback from anyone else via email or here. So let's move forward with you proposed solution. I'll add to kanban board.
Flags: needinfo?(akeybl)
(In reply to Jake Maul [:jakem] from comment #4)
> Comment 2 is a feature request for :rstrong / :akeybl, and there's probably
> no chance of doing that in time for this test.
> 
> Comment 3 is a feature request / confirmation for Rel-Eng (catlee)... I
> don't know how feasible that is, or indeed if it's already done. The primary
> concern as I see it would be if "firefox(-beta|-aurora)?-latest" will work
> with non win/en-US builds. We could probably get away with it for this test
> even if it only works with win/en-US, but that would make it unsuitable as a
> general solution... this is a publicly accessible page, so we cannot
> guarantee that all traffic to it will have come from stub installer.

Yeah, unfortunately firefox-(beta|aurora)-latest are win32 en-US only at this point.
Just so I'm 100% clear. This is only for the beta download button on that page so far right? This should NOT be the case for the aurora or release download buttons on the installer-help page?
(Reporter)

Comment 13

6 years ago
Paul the above matches with my understanding. I would like jake to confirm.
Flags: needinfo?(nmaul)
(In reply to Ben (:bensternthal) from comment #0)
> Timing wise we need to know:
> - When can this be tested?

On staging? I don't believe there's any blockers right now.

> - When can this go live

Given positive desktop QA testing, we can go live asap in concert with Jake's 50/50 rewrites (Jake, do we have a bug on this?)

> - When if ever should this be reverted back?

>48 hours after this bug is resolved.

Comment 15

6 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/205dad0bc4c20f556f4e85ac708c88f9c6405704
Bug 850295: Update download buttons for funnelcakes.

* Force funnelcake for en-US Windows release and beta buttons on
  installer-help page.

https://github.com/mozilla/bedrock/commit/2233e5a79d9269a51e0934e6f98f1173cacdc721
Merge pull request #681 from pmclanahan/bug-850295-add-button-version-override

Bug 850295: Update download buttons for funnelcakes.

Updated

6 years ago
Blocks: 850736

Comment 16

6 years ago
Confirmed via IRC to :pmac, this is for Beta. Release and Aurora are not part of this test.

Blocked IT bug added.
Flags: needinfo?(nmaul)
The fallback page is now on prod. Waiting to rewrites to be in place so  can test those too
These are the results from testing the rewrites in place.

firefox-20.0b4
 
240 = Location: https://download.mozilla.org/?product=firefox-20.0b4-funnelcake19&os=win&lang=en-US
260 = Location: https://download.mozilla.org/?product=firefox-beta-stub&os=win&lang=en-US

firefox-beta-latest

500 = Location: https://download.mozilla.org/?product=firefox-20.0b4-funnelcake20&os=win&lang=en-US



We can now ship this live
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(In reply to Alex Keybl [:akeybl] from comment #14)
> > - When if ever should this be reverted back?
> 
> >48 hours after this bug is resolved.

Actually, we'll pull this back at EOD on 3/22 - no need to cause further churn.
(Reporter)

Comment 20

6 years ago
Suggest we do EOD based on Eastern Time (5pm) and either on Thursday or Monday.

Unless this time is absolutely necessary I would not release code EOD friday.
Flags: needinfo?(akeybl)
(Reporter)

Comment 21

6 years ago
Alex:

Can you please advice on https://bugzilla.mozilla.org/show_bug.cgi?id=850295#c20 and provide your feedback?
Since 3/22 is risky, we'll need to leave the experiment up until Monday 3/25. Thursday would cut the experiment short.
Flags: needinfo?(akeybl)
(Reporter)

Comment 23

6 years ago
OK great confirming will pull this down

Monday 3/25 5pm Eastern Time

Comment 24

6 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/ac60477eed150ec2f0577334f642313734f39fb7
Bug 850295: Remove funnelcake download support from installer help page.

https://github.com/mozilla/bedrock/commit/f74a38bf30b689aa62cd8109edb93d9cbecf049e
Merge pull request #704 from pmclanahan/bug-850295-remove-funnelcake

Bug 850295: Remove funnelcake download support from installer help page.
(Reporter)

Comment 25

6 years ago
verifying funnelcake removed from production installer help page.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.