URL Bar Stuck on HTTPS in History

RESOLVED DUPLICATE of bug 769994

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 769994
5 years ago
5 years ago

People

(Reporter: philbar, Unassigned)

Tracking

19 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 724058 [details]
Screen Shot 2013-03-12 at 11.39.01 AM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

I visit http://www.bioworldusa.com constantly because it is our company website. Recently I created a local SSL certificate and went to https://www.bioworldusa.com. After finishing the work, I deleted the local SSL certificate.


Actual results:

Now every time I type in "bioworldusa.com" in the URL bar, it takes me to the https location which results in a server connection error. I have to then manually change https to http. It's very annoying and I don't know what to do apart from clearing all of my history.


Expected results:

I would think Firefox would detect the problem, and redirect me to the unsecured site since I am NOT manually typing https.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769994
You need to log in before you can comment on or make changes to this bug.