New PDF viewer doesn't display files at Vanguard.com

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: ron.l.johnson, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20131021][pdfjs-f-need-info])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307122903

Steps to reproduce:

Log into vanguard.com, click on "message center", click on a message, click on PDF link.

This may be associated with #474776 even though that bug uses the Adobe plugin.

Since you probably don't have a brokerage account with Vanguard, I'll do everything I can to cooperate with you diagnosing the problem.


Actual results:

The document opens in the new viewer window, but the page is completely white/blank.



Expected results:

The document displays correctly in the new viewer window.
>The document opens in the new viewer window, but the page is completely white/blank.
Do a ctrl+u to see the page source. You should be able to save the source from the view source viewer. Please attach the source here as file using the "add an attachment" link in this report.You may want to modify personal data in the source.

I suspect that they use an embed/object tag for the pdf and that would make it a dupe.
(Reporter)

Comment 2

6 years ago
Created attachment 724291 [details]
Example of PDF that displays only whiteness

In reply to request from developer.
Thanks !
Unfortunately they are using a frameset and the source doesn't contain the frame with the pdf :-(

Please do the following:
Open again the source of the popup (ctrl+U), hit ctrl+f to open the find bar and use frameset as search term. You should be able to follow the frame "pdf" source address link with a left click on it.
The line should start like the example from the attachment.

<frame name="pdf" src='/us/SecureMessageStreamController......

Click on the /us/Secure... line. That should open the source from the frame with the pdf. Can you please attach this source ?
(Reporter)

Comment 4

6 years ago
Since it's from my brokerage firm, it has -- as you may expect -- personal financial details that I don't want to share with other.

So, is there something in the source I can search for instead of uploading the whole document?
Is there an <embed> or <object> tag inside the source that links to the pdf ?
(Reporter)

Comment 6

6 years ago
The SecureMessageStreamController...... file that you asked me to look at in Comment 3?

No, neither of the words are in them.

Here are the first 50ish lines of the file:
%PDF-1.4
2 0 obj
<<
/Creator(Open Print - Copyright (c) 1997 SEFAS Technologies. All Rights Reserved)
/CreationDate(D:20130312103056)
/ModDate(D:20130312103056)
/Producer(Open Print Backstage VERSION 6.2.3.51)
/Author(Open Print)
/Title(/data/top/prd/vad/remake/conversion/remake_traffic/jobs/PDF/DLY_PDF/DLY_CONFIRMS_RTL/075868/075868-O01-0.lis)
/Subject(Driver PDF)
/Keywords(Open Print Driver PDF)
>>endobj
3 0 obj
<</Length 73>>
stream
1 0 0 -1 1 0 d1
q
1 0 0 1 0 -1 cm BI /W 1 /H 1 /BPC 1 /IM true ID
EI
Q

endstream
endobj
4 0 obj
<</Length 5>>
stream
q
Q
 
endstream
endobj
14 0 obj
<</Type /XObject
/Subtype /Image
/ImageMask false
/Name /Im0
/Width 608
/Height 166
/BitsPerComponent 8
/ColorSpace /DeviceRGB 
/Filter [/ASCIIHexDecode /FlateDecode]

/Length 29049
>>
stream
789CED9DBFAB2DC97DEDFFA0179BAB78100A85914371C1A16EA26870E2447E9102338A8CC0375320679AC0EF06231E621EE681119A4089C418A164845
0E0446350
E0A4FDE57CD88BEFADAAAEAEEAEEFDE39CBB16CD619FDEBDBBAB6B9F53ABBFBFD677590CE310FEFBEBFFFAEAD3CF7EF5FD1FFCFC1BDF79F7BFBE7564F
BC5B75EFF
E6873FFEF36F7F77EF7B320CC3308CFDF8CB1FFEF4EBBFFFC7839CD8DCFEED6FDE04E7DEFBFE0CC3300C630E61335E89190B96B42D691886613C17046
71D77A58E
Ron, can you still reproduce this issue with the newer Firefox versions?
Flags: needinfo?(ron.l.johnson)
(Reporter)

Comment 8

5 years ago
Yes, but...  In v22 or v23 someone added a "This PDF document might not be displayed correctly." alert message at the top of squirrely PDFs and an "Open With Different Viewer" button.

So, even though pdf.js still can't read them, FF will helpfully let me open them in poppler ("document viewer").
Flags: needinfo?(ron.l.johnson)

Comment 9

5 years ago
It may still be useful to show the PDF to the developers, if possible.
Component: Untriaged → PDF Viewer
Keywords: testcase-wanted

Updated

5 years ago
Whiteboard: [bugday-20131021]
When I click on a pdf link in the message center it prompts me with the open with/save as dialog. Is this still an issue for you?
Flags: needinfo?(ron.l.johnson)

Updated

5 years ago
Attachment #724291 - Attachment mime type: text/plain → text/html

Updated

5 years ago
Whiteboard: [bugday-20131021] → [bugday-20131021][pdfjs-f-need-info]
(In reply to Brendan Dahl [:bdahl] from comment #10)
> When I click on a pdf link in the message center it prompts me with the open
> with/save as dialog. Is this still an issue for you?

Same here. Closing this as WORKSFORME given the lack of reproducibility.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ron.l.johnson)
Keywords: testcase-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.