When working in conjuction with Jaws, the Focus 14 Blue braille display switches to computer braille mode when entering text in a Firefox text box.

RESOLVED INVALID

Status

()

Core
Disability Access APIs
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Len Burns, Unassigned)

Tracking

(Blocks: 2 bugs, {access})

19 Branch
x86_64
Windows 7
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

I entered text into a text box while using Jaws V14 and a Focus Blue 14 braille display.


Actual results:

In a typical edit, the Focus 14 with Jaws V14 respects the default settings in the Jaws options.  Typically this means the input mode is either contracted or uncontracted braille.  There are exceptions to this behavior such as the To and CCc fields in Thunderbird.  When I enter a text edit in Firefox, the braille display reports that it has switched to computer braille and the same is spoken by Jaws if speech is not silenced.  Since most casual users of a braille display are unfamiliar with computer braille, this matter could lead to serious confusion on the part of the user.


Expected results:

The braille display should respect its default input mode, either contracted or uncontracted braille.  It should be left to the user to choose to switch to computer braille if it is needed.
(Reporter)

Comment 1

5 years ago
This issue has been reported to Freedom Scientific and is currently under investigation.
Keywords: ecommerce
(Reporter)

Comment 2

5 years ago
It is noteworthy that similar behavior occurs in the Thunderbird composition window.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Untriaged → Disability Access APIs
Product: Firefox → Core
Not sure which component to put this in. Maybe Core::XUL? I wonder what Firefox is either telling or not telling in markup on textboxes that makes this behavior happen, if it is not a JAWS problem.
Keywords: ecommerce → access

Comment 4

5 years ago
Brett, can you take a look please?
Flags: needinfo?(blewis)

Comment 5

5 years ago
Not sure there is even anything in IAccessible2 that could tell JAWS from our end to switch to computer braille mode or not. I know that NVDA does not do this. Might be a JAWS problem, but let's wait for Brett's investigation.
(Reporter)

Comment 6

5 years ago
I received the following update from Freedom Scientific technical support this morning:
"After discussing this inquiry with our senior specialist, this ability is not possible because we are unable to access the edit fields the outlined applications in a manner that will allow us to capture the contracted input to be properly processed. Therefore, this ability is not available. "

Comment 7

5 years ago
I've been told that "This translation mode is what JAWS currently does not support in firefox.  This is really just a feature of JAWS and not a limitation in firefox.". So nothing to fix on our side. Closing the bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(blewis)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.