Right half of content is black until device is rotated on Nexus S

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: Margaret, Assigned: cwiiis)

Tracking

Trunk
Firefox 22
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified, firefox21 verified, firefox22 verified)

Details

Attachments

(2 attachments)

Reporter

Description

6 years ago
See the attached photo. I find this happens to any page I navigate to after starting the app from a killed state, but rotating the device or putting the app in the background fixes it.

I'm seeing this on today's mozilla-central on a Nexus S running 2.3.6.
Assignee

Comment 1

6 years ago
This is caused by the single-tile drawing path being broken. This has never worked, but the fix in bug 842389 causes the path to get hit. Patch incoming to just disable that path for now.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Assignee

Comment 2

6 years ago
The single-tile drawing path is broken and bug 842389 meant it rarely(/never?) got hit - comment out the code that could cause it to get hit until we fix it properly.
Attachment #724496 - Flags: review?(bgirard)
Assignee

Updated

6 years ago
Blocks: 842389
Comment on attachment 724496 [details] [diff] [review]
Always use the single paint buffer

I would be in favor of uplifting this. This only removes a buggy fast path.
Attachment #724496 - Flags: review?(bgirard) → review+
Assignee

Comment 5

6 years ago
Comment on attachment 724496 [details] [diff] [review]
Always use the single paint buffer

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Corrupt/missing content
User impact if declined: Bad, obvious rendering glitches in not-too-uncommon circumstances
Testing completed (on m-c, etc.): Local testing, just disables a faulty code-path that we thought was already disabled
Risk to taking this patch (and alternatives if risky): Low, required for bug 842389
String or UUID changes made by this patch: None
Attachment #724496 - Flags: approval-mozilla-beta?
Attachment #724496 - Flags: approval-mozilla-aurora?
Comment on attachment 724496 [details] [diff] [review]
Always use the single paint buffer

Taking this to branches to help with issues in bug 842389 - we'll want to verify this doesn't cause regressions in the beta building today, if it does we'll back both 842389 and this fix from our next-to-last beta and let it all ride the trains.
Attachment #724496 - Flags: approval-mozilla-beta?
Attachment #724496 - Flags: approval-mozilla-beta+
Attachment #724496 - Flags: approval-mozilla-aurora?
Attachment #724496 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/d0ad849d2bd0
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22

Updated

6 years ago
Blocks: 807299
Status: RESOLVED → VERIFIED

Comment 9

6 years ago
Verified on Firefox for Android 21.0b7 using: Nexus 4 (4.2.2) and Samsung Galaxy R (2.3.4)
You need to log in before you can comment on or make changes to this bug.