Inject `addon` to the addon-page context

RESOLVED DUPLICATE of bug 850449

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 850449
5 years ago
5 years ago

People

(Reporter: ochameau, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Currently, we have to use custom PageMod instance in order to be able to communicate with the addon-page. And it also forces to use a contentScript to communicate with it whereas it is a trusted document so that we could inject `addon` object in the document's scope, like what we are doing for Panel/Widget.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 850449
You need to log in before you can comment on or make changes to this bug.