Closed Bug 850483 Opened 7 years ago Closed 7 years ago

Send blocklist ping info as part of FHR payload

Categories

(Firefox Health Report Graveyard :: Client: Desktop, defect, P4)

defect

Tracking

(firefox20 unaffected, firefox21+ verified, firefox22+ verified)

VERIFIED FIXED
Firefox 22
Tracking Status
firefox20 --- unaffected
firefox21 + verified
firefox22 + verified

People

(Reporter: gps, Assigned: gps)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #849947 +++

One of the action items from bug 849947 is to send some metadata about the Blockist Ping with the FHR payload.

There is discussion in that bug on what exactly we should send. Let's move that discussion here.
P4 unless we have a concrete need for this sooner.
Priority: -- → P4
This is a critical part of solving bug 849947. I believe this should be the same priority as bug 849947 (which is currently P1).
This is a partial solution. Like Telemetry in bug 837292, we now record a per-day flag indicating whether the blocklist is enabled.

I say this is a partial solution because it doesn't paint a full picture: we still don't know if the blocklist was successfully sent. However, if a large percentage of clients report blocklist is disabled, then that could explain the discrepancy between FHR and blocklist count.
Attachment #725470 - Flags: review?(rnewman)
Comment on attachment 725470 [details] [diff] [review]
Record "blocklist enabled" in FHR, v1

Review of attachment 725470 [details] [diff] [review]:
-----------------------------------------------------------------

Copypasta, ho!
Attachment #725470 - Flags: review?(rnewman) → review+
Flagging as depends for landing pleasure.
Assignee: nobody → gps
Status: NEW → ASSIGNED
Depends on: 837292
https://hg.mozilla.org/services/services-central/rev/5645c4612346

If we want more detailed blocklist info in the FHR payload, please file a new bug.
Status: ASSIGNED → NEW
Whiteboard: [fixed in services]
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/5645c4612346
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed in services]
Target Milestone: --- → mozilla22
(In reply to Gregory Szorc [:gps] from comment #7)
> https://hg.mozilla.org/mozilla-central/rev/5645c4612346

Needed in 21 on Aurora?
(In reply to Alex Keybl [:akeybl] from comment #8)
> (In reply to Gregory Szorc [:gps] from comment #7)
> > https://hg.mozilla.org/mozilla-central/rev/5645c4612346
> 
> Needed in 21 on Aurora?

I believe so, yes. However, we are waiting on final confirmation from Privacy that this implementation is acceptable.
(In reply to Gregory Szorc [:gps] from comment #9)
> (In reply to Alex Keybl [:akeybl] from comment #8)
> > (In reply to Gregory Szorc [:gps] from comment #7)
> > > https://hg.mozilla.org/mozilla-central/rev/5645c4612346
> > 
> > Needed in 21 on Aurora?
> 
> I believe so, yes. However, we are waiting on final confirmation from
> Privacy that this implementation is acceptable.

Thanks ! Can we please add needinfo to speed up the needed privacy review here in case the request in 849947 does not cover this .
Answers were obtained in bug 855710. Will proceed with uplift request.
Comment on attachment 725470 [details] [diff] [review]
Record "blocklist enabled" in FHR, v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FHR
User impact if declined: We won't have blocklist enabled visibility until Firefox 22.
Testing completed (on m-c, etc.): It has baked for many days without issue.
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None

This patch depends on all the patches in bug 837292.
Attachment #725470 - Flags: approval-mozilla-aurora?
Attachment #725470 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I can see the following in my latest payload:
> "org.mozilla.appInfo.appinfo": {
>           "_v": 2,
>           "isBlocklistEnabled": 1

Is that the scope of this bug or should I be able to see blocklist changes from a blocklist ping in my payload as well?
The simple flag was the scope for this bug.
(In reply to Gregory Szorc [:gps] from comment #15)
> The simple flag was the scope for this bug.

Thanks Gregory, I confirm the flag exists in both Nightly and Aurora. Marking this bug verified fixed.
Status: RESOLVED → VERIFIED
Component: Metrics and Firefox Health Report → Client: Desktop
Flags: in-testsuite+
Product: Mozilla Services → Firefox Health Report
Target Milestone: mozilla22 → Firefox 22
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.