DevTools could use some event handler inspection logic

RESOLVED DUPLICATE of bug 736078

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 736078
5 years ago
5 years ago

People

(Reporter: miker, Assigned: miker)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

There is an excellent bookmarklet called Visual Events:
http://www.sprymedia.co.uk/article/Visual+Event+2

This would allow users to see events attached to node (via jQuery etc.)

We should implement an API that allows to gather this information so that it can be displayed:
- When inspecting via the markup view.
- When a node is locked (next to the selector).
- Via GCLI ... page overlay containing all information:
  a. in boxes next to each element containing events.
  b. in a box next to a specific element.
Duplicate of this bug: 851478
Summary: Add event information to developer tools → DevTools could use some event handler inspection logic
Jim's comments from bug 854439 should be useful here.

Comment 3

5 years ago
This is actually also a dupe of bug 736078 from a year ago.
So it is.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 736078
You need to log in before you can comment on or make changes to this bug.