[NEWS] last news message doesn't display in thread pane

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: scurtis, Assigned: sspitzer)

Tracking

Trunk
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
This is going to sound a little strange.

It seems to me that I don't get a freshly-sent news post from the server (when I
hit "get msg") until another news post has queued up behind it. I still need to
demonstrate that this is really cross-platform, though I imagine it'd have to
be.

Get this, though:

1. I posted Post 1 and Post 2 to mcom.test.
2. Only Post 1 showed up. I waited about 5-10 minutes. Clicked (again) Get Msg.
Nothing.
3. I exited and restarted seamonkey. Clicked Get Msg. Still no Post 2.
4. I sent Post 3. Clicked Get Msg. Post 2 shows up. Waited a while. Get Msg.
Still no Post 3.
5. Sent Post 4. Get Msg. Post 3 immediately shows up. No sign of Post 4. And so
on.

RedHat 5.2 June 18th build.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → scurtis
Summary: [NEWS] Not retrieving most recent news message from server? → [NEWS] Not retrieving most recent news message from server?

Comment 1

19 years ago
fyi: I don't see this problem on the 6/18 build on Win32.  I tried the
following:

1) Get msgs first to get all messages from netscape.test
2) Post message a and post message b
3) Get msg.  Both a and b came in.

1a)  Get msgs first to get all messages from netscape.test
2a)  Post message a.
3a)  Get msg.  Message a came in.
4a)  Post message b.
5a)  Get msg.  Message b came in.
(Reporter)

Comment 2

19 years ago
I'm not seeing this behavior in the 6_19 Linux build...I'd like to leave it open
for a few more days to see if I see it again, or if other conditions are
necessary to see it....
(Reporter)

Updated

19 years ago
Summary: [NEWS] Not retrieving most recent news message from server? → [NEWS] last news message doesn't display in thread pane
(Reporter)

Comment 3

19 years ago
Ok, changing summary. I'm seeing it in the 6_21m7 build, too, and have a little
better handle on it. It's a display issue, where if you have more news messages
in the thread pane than fit in the pane (so you have a scroll bar), the
bottom-most message won't be visible in the thread pane. The scroll bar looks
like it's at the bottom, but it's not. I can find the expected last message if I
choose a different sort method.

So far, this is only tested on Linux. It doesn't seem to affect mail, strangely
enough. More info tomorrow.
(Reporter)

Comment 4

19 years ago
I can reproduce this at will with the 6/22 M8 Linux build. I have max_articles
set to 50, and am using the mcom.test newsgroup. I can't reproduce it on
6/22 Windows.

Comment 5

19 years ago
Ninoschka is seeing this type of problem on Linux with IMAP only where the last
message to be received doesn't show up.  She'll investigate more Monday, but
wanted to update this since it's similar to this bug.  After investigations, if
this warrants a new bug, we'll file one.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
with the new scroll bar in the read pane, I can get to the last message in the
thread pane.

marking worksforme.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
And then some!

This should fix Ninoschka's problem, too, as the new scroll bar has the same
effect in mail as in news. (She's on cc.)

Verified wfm, 7_7 Linux build.

Comment 8

19 years ago
1999070708M8: Linux/Redhat 5.2

I no longer see the problem so it appears fixed on IMAP too.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.