[Open_][Gallery]longKey set the Gallery albums to wallpaper, the crop box and picture don't match.(617001922211)

RESOLVED DUPLICATE of bug 846236

Status

Firefox OS
Gaia::Gallery
RESOLVED DUPLICATE of bug 846236
5 years ago
5 years ago

People

(Reporter: Firefox_Mozilla, Assigned: diego)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 724317 [details]
screenshot

Steps to reproduce:
1. LongKeydown idle set wallpaper,select Gallery;
2. Select a photo set, see the crop box;
Actual results:
Crop box does not match with selected picture, see attached file;
Expected results:
Crop box match Selected picture
mozilla build id:20130225070200(AU025)
(Reporter)

Updated

5 years ago
Blocks: 845223
blocking-b2g: --- → tef?
Assuming we still have this issue on the tip, tef+ as it's pretty broken UI.

qawanted to check if this is still seen at tip please!
blocking-b2g: tef? → tef+
Keywords: qawanted
Created attachment 724500 [details]
selection to crop after selecting image from gallery

It matches somewhat.   It's asking to crop the gallery image so that it fits the screen.
Created attachment 724501 [details]
screenshot after cropped selection.

screenshot after cropped selection.
Looking at the images... I don't really think this is a bug, unless I'm not understanding what's being reported?
Flags: needinfo?(mvines)
fyi : I used 

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/2a8c49f56bb6
Gaia   acd6546cdd03284b3b8c12432fb9955868fc4c2b
BuildID 20130313070202
Version 18.0
Keywords: qawanted
Flags: needinfo?(mvines) → needinfo?(Firefox_Mozilla)
I cannot reproduce this issue with the latest beta build,
 - Build ID: 20130314114915
 - Channel: beta


I think the bug reported is about the size of crop box (white box) does not match the image.
Take attachment 724317 [details] as an example, the top and the bottom edge of the crop box should hover the picture's edges.

Could someone provide the image used to reproduce this issue?

Thanks.
(Reporter)

Comment 7

5 years ago
we add an image which can reproduce this issue. it can use this image to try.
Flags: needinfo?(Firefox_Mozilla)
(Reporter)

Comment 8

5 years ago
Created attachment 725239 [details]
image
(Reporter)

Comment 9

5 years ago
The attachment 725239 [details] can reproduce this issue in build ID:20130225070200. It means the size of crop box (white box) does not match the image, which mentioned in comment 7 .
I cannot reproduce with the attached image (attachment 725239 [details]) and the same build 20130225070200.
The build should be this one on v1.0.1,
https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18_v1_0_1-unagi/2013/02/2013-02-25-07-02-00/

Please note that this looks the same as case 1 (landscape picture, attachment 716476 [details]) in Bug 826211, and we could not reproduce case 1 in that bug.

Mark testcase-wanted for help to get to the specific case as case 1.
Keywords: testcase-wanted
ni(reporter) as we wait for a test case
Flags: needinfo?(Firefox_Mozilla)
Placing back on the nom list since all signs point to this being either a one-off image issue or completely unreproducible.
blocking-b2g: tef+ → tef?
(clearing tef? flag for now pending more detail from reporter.)
blocking-b2g: tef? → ---
(Reporter)

Comment 14

5 years ago
we still can reproduce it in build 20130310070203. Is it caused by hwcomposer?
Flags: needinfo?(Firefox_Mozilla)
Maybe, what do you think Diego?
Flags: needinfo?(dwilson)
(Assignee)

Comment 16

5 years ago
Yeah, looks like hwcomposer is missing some offset
Assignee: nobody → dwilson
Flags: needinfo?(dwilson)
(thanks, tef+ and please to be fixing)
blocking-b2g: --- → tef+
Flags: in-moztrap?
Which device did you use?
Flags: needinfo?(Firefox_Mozilla)
(Assignee)

Comment 19

5 years ago
I found the problem. HwcComposer2d is not handling the combination of rotation and Y-axis flip at the same time. Since this is an uncommon use case I'll just make it fallback to GPU rendering.
(Assignee)

Comment 20

5 years ago
Oops, please ignore comment 19. It was intended for bug 846236
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 21

5 years ago
Turns out this bug has the same root cause as bug 846236. More details there.
Depends on: 846236
If it's the same root cause, closing the issue as a dup of that bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(Firefox_Mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 846236
Steps are not clear on how to reproduce this issue for unagi.  Marking the other bug as test case wanted.
Flags: in-moztrap? → in-moztrap-
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.