PDF Viewer should ignore fonts set by the user in Firefox Options

RESOLVED DUPLICATE of bug 738627

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED DUPLICATE of bug 738627
5 years ago
5 years ago

People

(Reporter: mjh563, Unassigned)

Tracking

20 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-integration])

(Reporter)

Description

5 years ago
It seems that the PDF viewer incorrectly takes into account the font settings in Firefox Options, so that if the user chooses to customise the fonts used for viewing web page content, those fonts are also used for displaying PDF documents.

Steps to reproduce:

1. Start Firefox using a new profile
2. In Options, go to Content > Fonts & colours > Advanced and untick the "Allow pages to choose their own fonts" checkbox
3. Change the 'Serif' and 'Sans-serif' fonts to something non-standard, eg. Comic Sans MS
4. Open http://www.raib.gov.uk/cms_resources.cfm?file=/130311_B012013_Four_Lane_Ends.pdf

Expected results:

The PDF should be displayed using the correct font(s) for that document. The same as it would be when viewed in an external viewer.

Actual results:

The PDF is displayed using whatever weird and wacky font I've chosen to view web pages in.

In addition, when any user-selected font is used, certain characters in PDF documents are not displayed correctly, and are replaced by some Chinese or other random character. This seems to happen regardless of which particular font is selected.

In the linked PDF for example, all 'fi' and 'fl' characters are displayed incorrectly when the "Allow pages to choose their own fonts" checkbox is unticked.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Duplicate of this bug: 851369

Updated

5 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-integration]

Comment 2

5 years ago
This bug should actually be a dup of bug 738627, which is unfortunately resolved as WONTFIX.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738627
You need to log in before you can comment on or make changes to this bug.