If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox for Android does not use the systems download manager mechanism

RESOLVED DUPLICATE of bug 816318

Status

()

Firefox for Android
Download Manager
RESOLVED DUPLICATE of bug 816318
5 years ago
a year ago

People

(Reporter: Jostein Kjønigsen, Unassigned)

Tracking

19 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Tried to download a file.


Actual results:

Firefox started downloading the file using its own download manager.

Android already has a download manager.


Expected results:

Android's built in download manager should be used.
(Reporter)

Updated

5 years ago
OS: Windows 8 → Android
Hardware: x86_64 → ARM
See bug 752014.

We're not using the system download manager due to permissions and at the time of initial implementation not all versions of Android had a download manager

* In order to add a download to the system download manager _without_ showing a system notification (since we already do that ourselves) we need a special permission:

DOWNLOAD FILES WITHOUT NOTIFICATION
Allows the app to download files through the download manager without any notification being shown to the user.

Wich was deemed  scary to a user at the time.

Although these days in ICS and Jellybean the permission is written as "Modify or delete the contents of your USB storage" ... perhaps one day we can entertain the idea of reverting back to the native download manager.

CC'ing Finkle
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

5 years ago
Obviously I can't speak for everyone, but given the current list of permissions (which is, ahem, a tad big), I can't say that those extra permissions would stop me from downloading a browser from one of Internet's most reputable organizations.

I think "getting this one right" would show some attention to detail which matters in everyday usage. Having your download-manager with its own slightly different icon, and slightly different behaviour is just jarring on a very subconscious level.
I wrote a patch to do this once and discovered that the system download manager is actually kinda awful (see bug 816318, i.e. we'd have to give up a bunch of features our current download manager has and in return we get... a list).

I think maybe a better alternative would be to just use it as a secondary place to show downloads (after they complete but not in progress?), but not actually USE it do download files.
NOTE: We'd have to do that only on HC+ phones, which I'd be fine with.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 816318
You need to log in before you can comment on or make changes to this bug.