If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

BiWeekly Multiday recurring events are created wrong.

NEW
Unassigned

Status

Calendar
Internal Components
5 years ago
2 years ago

People

(Reporter: Marko Järvenpää, Unassigned)

Tracking

Lightning 1.9

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Well, basically just create a Recurring event, custom, weekly, interval 2, select all days (MO-SU) And create.



Actual results:

For example, I create it starting from 2013-1-1 and the first occurences are 7th, 8th, 9th, 10th, 11th, 12th and 13th (+1st since lightning creates event for the selected day too). 


Expected results:

Occurences should be 1st, 2nd, 3rd, 4th, 5th, 6th and after that the 2 week interval.

Google implements it this way, and also if you import an iCal file with this rule (RRULE:FREQ=WEEKLY;INTERVAL=2;BYDAY=SU,MO,TU,WE,TH,FR,SA and DTSTART;20130101T080000Z), it is imported correctly. 
So the issue is only when you create it in the lightning.

Comment 1

2 years ago
In Bug 566149 has been decided that the Edit dialog must keep the until date when changing the start date so marking this as duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 566149

Comment 2

2 years ago
Sorry wrong bug.
Confirm this one anyway.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Updated

2 years ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.