Unable to Sync: Unknown error

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: Backend
RESOLVED WORKSFORME
5 years ago
8 months ago

People

(Reporter: Rune Juhl Jacobsen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 724348 [details]
about:sync-log

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130308124351

Steps to reproduce:

Recently installed Ubuntu and copied old /home from a previous Debian install. Running 19.0.2 from Ubuntu 13.04 repositories.


Actual results:

Sync stopped working with the following error: "Sync encountered an error while syncing: Unknown error."

At the same time, somewhat similar to https://bugzilla.mozilla.org/show_bug.cgi?id=769323 , I've got 74 folders containing "Mobile Bookmarks" -- but inside they're all similar as they contain the same bookmarks.
I've tried deleting the bookmarks inside, and it works but for one. The deleted bookmarks disappear from all "Mobile Bookmarks" folders. The last bookmark I'm unable to delete or cut and paste in a different folder.


Expected results:

Sync should continue working. I should be able to delete bookmarks.
(Reporter)

Comment 1

5 years ago
I'm also unable to add bookmarks, and recently visited pages does not always show up in the URL bar as suggestions.
(Reporter)

Comment 2

5 years ago
I've now tried dumping places.sqlite, removing the corresponding bookmarks and restoring the database, but upon starting Firefox, all bookmarks are gone.
Exporting to json works, but importing results in all but a handful of the oldest bookmarks. The exported json is valid. It seems that all bookmarks with tags are skipped.
Exporting to html doesn't work -- no file is written.

Updated

5 years ago
Component: Untriaged → Firefox Sync: Backend
Product: Firefox → Mozilla Services
Version: 19 Branch → unspecified

Comment 3

8 months ago
Sorry for the delay, but we've done alot of work on bookmark syncing over the last 5 years - please let us know if you continue to see issues.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.