Keyboard displayed regression on 2013-03-08 when loading page via am

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: bc, Assigned: jchen)

Tracking

({regression})

Trunk
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 724437 [details]
webfiles.zip (contains the relevent web pages)

Beginning on 2013-03-08 on Android 2.{2,3} phones we have begun seeing the keyboard opening when loading pages for the Autophone s1s2 tests. This appears to happen only for Android 2.2, 2.3 on nexus s, droid pro, nexus one. I can't reproduce with a gs2 on 2.3 or 4.0.

I've only seen this on the startup6.html page though Mark has also seen it in the Twitter2.html page.

This does not appear to happen when loading the page manually but only via am.

am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App --es args '--profile /mnt/sdcard/tests/autophone/profile' -d http://192.168.1.13:8100/startup6.html

am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App --es args '--profile /mnt/sdcard/tests/autophone/profile' -d http://192.168.1.13:8100/Twitter2.html
How different are autophone profiles from regular profiles? I couldn't reproduce this on my 2.3.6 Motorola device, by running with a fresh profile,

> am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d http://people.mozilla.com/~nchen/tests/webfiles/startup6.html

But maybe my device is not one that's affected.
(Reporter)

Comment 2

6 years ago
Created attachment 724607 [details]
profile.tar.bz2

This is a profile from a nexus one after the tests have run.
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Priority: -- → P2
Not sure if this still applies. I was never able to reproduce it.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.