URL strings with non-latin letters shouldb be copied as UTF, not as special-encoded

RESOLVED DUPLICATE of bug 413083

Status

()

RESOLVED DUPLICATE of bug 413083
6 years ago
5 years ago

People

(Reporter: benderamp, Unassigned)

Tracking

19 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20131125])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Open wikipedia with any non-latin article:
http://ru.wikipedia.org/wiki/Красота

And then copy url and paste to some text editor or document (for example to email body editor).



Actual results:

Pasted text would look like 
http://ru.wikipedia.org/wiki/%D0%9A%D1%80%D0%B0%D1%81%D0%BE%D1%82%D0%B0

Which is not readable by human.


Expected results:

Link should be pasted as 
http://ru.wikipedia.org/wiki/Красота

Which is readable by human and is shown in URL field in this way.
can be intentional like bug 458565
Component: Untriaged → Location Bar

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [bugday-20131125]
Duplicate of bug: 413083
You need to log in before you can comment on or make changes to this bug.