Include detection for ATL lib from Windows Driver Kit Version 7.1.0

RESOLVED WONTFIX

Status

mozilla.org
MozillaBuild
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: rsilveira, Unassigned)

Tracking

Details

To compile metro firefox with visual studio express, we're recommending installing WDK 7.1 from http://www.microsoft.com/en-us/download/details.aspx?id=11800 to get the needed ATL headers and libs. 

It would be nice if it was detected automatically and added to the inc folder.

Our current instructions are in https://wiki.mozilla.org/Firefox/Windows_8_Integration#Building_Locally
We should also document the WDK7.1 requirement in the "Windows Build Prerequisites":
  https://developer.mozilla.org/en-US/docs/Developer_Guide/Build_Instructions/Windows_Prerequisites

WDK7.1 (specifically just the ATL headers and libs) is required for anyone who is using VC10+ Express
...if they intend to build with --enable-metro (which someday will be the default on Windows builds I imagine?)
Given the current state of Metro support, I leaning towards this being wontfix.
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
Yep, calling this WONTFIX until Metro becomes something we officially need to support again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.