Closed Bug 850979 Opened 10 years ago Closed 10 years ago

[Buri][Bluetooth]Can not switch audio into MS when connected BT headset

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:-)

RESOLVED DUPLICATE of bug 830213
blocking-b2g -

People

(Reporter: sync-1, Assigned: echou)

Details

(Whiteboard: IOT, Chile, Ikura, khepera_43504)

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #415620 +++
 
 DEFECT DESCRIPTION:
 Can not switch audio into MS when connected BT headset
 
 REPRODUCING PROCEDURES:
 1.Connected a BT headset
 2.Incoming/ougoing a call,audio output from BT headset,then switch to speaker OK
 3.But can not find any icon to swith audio into MS-->KO
 
 EXPECTED BEHAVIOUR:
 For KO,Should can switch audio into MS when connected BT headset
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 B2G-4231
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:
 Mozilla build ID: 20130304070202.
 ++++++++++ end of initial bug #415620 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
 DEFECT DESCRIPTION:
 
 REPRODUCING PROCEDURES:
 
 EXPECTED BEHAVIOUR:
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:
1.MS means audio output from phone,and can not switch audio from BT headset to phone,only can switch to speaker when incoming/outoing a call.
 2.KO means not OK,its
Created an attachment (id=373251)
 Beetle lite FF behavior
Attached image Beetle lite FF behavior
Created an attachment (id=373251)
 Beetle lite FF behavior
Created an attachment (id=373253)
 other phone behavior
Attached image other phone behavior
Created an attachment (id=373253)
 other phone behavior
blocking-b2g: --- → tef?
Priority: -- → P1
triage: dcoloma will follow up and understand if this is blocking for release markets
Assignee: nobody → echou
Flags: needinfo?(dcoloma)
(In reply to comment #4)
 > Comment from Mozilla:triage: dcoloma will follow up and understand if this is
 > blocking for release markets
 > 
 
 to test and pass BT PTS certification, HFP/HSP need support switch between MS and BT headset during call.
 
 this is mandatory to get fixed, otherwise BT PTS certification will fail.
David, is BT PTS certification mandatory for Telefónica? Do you think this is blocking for TEF Certification?
Flags: needinfo?(dcoloma) → needinfo?(dpv)
Hi, 

Bluetooth certificate is requested during certification in Spain and Venezuela (at least). So if this is blocking BT certificate, I think we should fix this. 

Adding dep to certification meta bugs.
Flags: needinfo?(dpv)
blocking-b2g: tef? → tef+
(In reply to sync-1 from comment #1)
> 1.MS means audio output from phone,and can not switch audio from BT headset
> to phone,only can switch to speaker when incoming/outoing a call.

First of all, according to reporter's description, the problem is that we can switch between speaker and one another audio output, such as headset on the phone and Bluetooth headset (if it's connected), but it's unable to let user choose the audio output if there are more than two available output devices (e.g. phone headset/speaker/Bluetooth headset). Having said that, I would say this is more like a feature of dialer.

In addition, I just checked the HFP spec and test spec, current implementation should be enough to pass BT certification since we can prove that audio transfer can be done between AG and HF.

Re-nominate as tef? and ni? to the reporter based on my comment.
blocking-b2g: tef+ → tef?
Flags: needinfo?(sync-1)
Attached file HFP1.5 cases
Need to switch audio from phone to BT headset,so need to resolve this bug,you
can refer to attachment,about HFP 1.5 cases.
Thanks!
adding some colleagues in CC
BT certification cases need switch audio between phone and BT headset.
 If this issue will not be fixed,we can not do it ,
 
 block BT certification
Flags: needinfo?(sync-1)
I have read section 4.17 of the spec and I see nothing we don't support yet, the spec does not specify if the call should be forwarded to the speaker or not, just to the mobile. I agree with comment 10 that the current implementation (although not ideal) should suffice to pass the certification test. Can anyone point to the relevant *test* that this implementation will not pass?
blocking-b2g: tef? → ---
Whiteboard: IOT, Chile, Ikura
In PTS cases(for BT certification),when test phone connected to PTS,means connected to PTS-HFP(BT headset).
 And cases need to switch to phone,so how should I do ?
(In reply to sync-1 from comment #15)
> In PTS cases(for BT certification),when test phone connected to PTS,means
> connected to PTS-HFP(BT headset). And cases need to switch to phone,so how should I do ?

You can switch audio to the speaker of the phone by pressing the speaker icon. That should work.
(In reply to comment #15)
 > Comment from Mozilla:(In reply to sync-1 from comment #15)
 > > In PTS cases(for BT certification),when test phone connected to PTS,means
 > > connected to PTS-HFP(BT headset). And cases need to switch to phone,so how should I do ?
 > You can switch audio to the speaker of the phone by pressing the speaker icon.
 > That should work.
 
 But in fact,cases can not pass according to your spec,must swith from BT headset to  phone
 And do you do any PTS cases?
(In reply to sync-1 from comment #17)
> (In reply to comment #15)
>  > Comment from Mozilla:(In reply to sync-1 from comment #15)
>  > > In PTS cases(for BT certification),when test phone connected to
> PTS,means
>  > > connected to PTS-HFP(BT headset). And cases need to switch to phone,so
> how should I do ?
>  > You can switch audio to the speaker of the phone by pressing the speaker
> icon.
>  > That should work.
>  
>  But in fact,cases can not pass according to your spec,must swith from BT
> headset to  phone

Speaker is on the phone. The main idea of this test should be proving that the audio can be switched between AG and HF, no matter what audio output device is. What if my mobile phone doesn't have any audio output except a speaker? Like Daniel said in comment 14, it's not a perfect solution but should be sufficient for cert.

>  And do you do any PTS cases?

Which test case can't it pass? Could you paste the whole test case here please?
(In reply to comment #17)
 > Comment from Mozilla:(In reply to sync-1 from comment #17)
 > > (In reply to comment #15)
 > >  > Comment from Mozilla:(In reply to sync-1 from comment #15)
 > >  > > In PTS cases(for BT certification),when test phone connected to
 > > PTS,means
 > >  > > connected to PTS-HFP(BT headset). And cases need to switch to phone,so
 > > how should I do ?
 > >  > You can switch audio to the speaker of the phone by pressing the speaker
 > > icon.
 > >  > That should work.
 > >  
 > >  But in fact,cases can not pass according to your spec,must swith from BT
 > > headset to  phone
 > Speaker is on the phone. The main idea of this test should be proving that the
 > audio can be switched between AG and HF, no matter what audio output device is.
 > What if my mobile phone doesnt
The continue of comment 19:

> ...   ...
> Which test case can't it pass? Could you paste the whole test case here please?

Now I can not verify for PTS cases,because on our test phone 121 version,can
not connected to PTS-HFP.But I use other phone try,can swith from BT headset to
speaker.
Thanks!
(In reply to comment #19)
 > Comment from Mozilla:The continue of comment 19:
 > > ...   ...
 > > Which test case cant
(In reply to Mingming ZHAO from comment #20)
> The continue of comment 19:
> 
> > ...   ...
> > Which test case can't it pass? Could you paste the whole test case here please?
> 
> Now I can not verify for PTS cases,because on our test phone 121 version,can
> not connected to PTS-HFP.But I use other phone try,can swith from BT headset
> to speaker.

I don't quite understand. Are you saying that you couldn't switch audio during a phone call even if you press the speaker icon?
Summary: [Buri][BT]Can not switch audio into MS when connected BT headset → [Buri][Bluetooth]Can not switch audio into MS when connected BT headset
blocking-b2g: --- → tef?
triage: not a blocker for tef
blocking-b2g: tef? → -
blocking-b2g: - → tef?
Whiteboard: IOT, Chile, Ikura → IOT, Chile, Ikura, khepera_43504
Still not a blocker from Telefonica's perspective, unless John can better explain his nomination.
Flags: needinfo?(jhammink)
Triage concurred: not blocking. If there's further reason to block, please renominate with explanation.
blocking-b2g: tef? → -
Flags: needinfo?(jhammink)
Based on Comment 13, I am sure 1.0.1 had fixed this bug. It's duplicate of 830213.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.