Remove Google as a content handler for feeds, because Reader and iGoogle are being discontinued

RESOLVED FIXED in Firefox 22

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: fryn, Assigned: fryn)

Tracking

Trunk
Firefox 22
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox -)

Details

Attachments

(1 attachment)

Assignee

Description

6 years ago
Posted patch patchSplinter Review
This was spun off from the wontfix'd bug 840710, because Google is discontinuing both Reader and iGoogle, the two services linked from fusion.google.com, one of our content handlers for feeds.

Because Google is currently first in the default list, and we'd have to shift Yahoo! to become the first item in the .properties file, I'm not sure what a patch for this should look like. I've attached one possibility.
From the localization point of view, changing the strings would be better, because translators will be shown that the entities browser.contentHandlers.types.1.title
and browser.contentHandlers.types.1.uri have been removed. Posting to mozilla.dev.l10n.announce will make most people aware of this, but doesn't guarantee that everybody notices that the 0 strings have to be updated.

This will also need backporting to the Firefox 17.0.* branch.
region.properties doesn't work like other l10n files, added/removed entities don't exist.

I'm afraid we'll need to actually do the leg work and do a per-purpose patch per locale.

Milos, can you help with that?
Axel, sure. Once this lands on mozilla-aurora, I'll script something to remove them all.
We should not default to yet another online service that might just as well die, with yet another painful migration.
The default is to subscribe to the feed as "Live bookmarks" which adds a "virtual" folder with the feed items as something like bookmarks.

The other items in the dropdown of the feed view (order preserved):
Choose Application...
Google
My Yahoo!
Assignee

Comment 6

6 years ago
(In reply to Axel Hecht [:Pike] from comment #2)
> region.properties doesn't work like other l10n files, added/removed entities
> don't exist.

(In reply to Milos Dinic [:Milos] from comment #3)
> Axel, sure. Once this lands on mozilla-aurora, I'll script something to
> remove them all.

Does this mean that the patch I wrote is sufficient for land this on mozilla-central?
Comment on attachment 724821 [details] [diff] [review]
patch

Review of attachment 724821 [details] [diff] [review]:
-----------------------------------------------------------------

r=me on the patch as is.

Milos, mind posting in the newsgroup alerting the folks on central?

My suggestion would be to whitelist landings that remove the google reader and just that, similar to what we did for the keyword url. And then we can fix the ones that don't remove it themselves afterwards with more paperwork?
Attachment #724821 - Flags: review+
Assignee

Updated

6 years ago
Attachment #724821 - Attachment description: possible patch → patch
Attachment #724821 - Flags: review?(gavin.sharp)
Assignee

Updated

6 years ago
Status: NEW → ASSIGNED
Attachment #724821 - Flags: review?(gavin.sharp) → review+
Assignee

Comment 8

6 years ago
Thank you for all the info, Axel and Milos.
I pushed this to mozilla-inbound, so it'll be merged to mozilla-central with a day or two.

https://hg.mozilla.org/integration/mozilla-inbound/rev/300c0d09903d

Ah, shoot. I forgot to add r=gavin to the commit message. Probably not worth backing myself out and re-pushing for that. Thank you for the review, and sorry about that, Gavin.
Target Milestone: --- → Firefox 22
https://hg.mozilla.org/mozilla-central/rev/300c0d09903d
Assignee: nobody → fyan
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 851852
Just wanted to call out that this landing for the first time in FF22 (released 2013-06-25) gets the change out in time for the Google Reader shutdown (7/1).
We discussed, not worth relnoting since Google has already announced.
Milos, did you post this?

Also, this should now be on aurora, should we have an additional bug for the l10n landings?
Flags: needinfo?(milos)
I'm looking through a list, and I can't really find that message. I'm pretty sure I posted it, though.
Flags: needinfo?(milos)
http://mxr.mozilla.org/l10n-mozilla-beta/search?string=browser.contentHandlers.types.0.title=G
finds 72 matches and these builds still contain "Google" as content handler for feeds. I can't find a post about this to mozilla.dev.l10n, but also can't find the discussion which I believe we had about automatic removing/altering this.
Flags: needinfo?(milos)
(In reply to Archaeopteryx [:aryx] from comment #15)
> http://mxr.mozilla.org/l10n-mozilla-beta/search?string=browser.
> contentHandlers.types.0.title=G
> finds 72 matches and these builds still contain "Google" as content handler
> for feeds.

Actually I believe that there are a lot more, since some locales have Google Reader as second or third choice.

http://mxr.mozilla.org/l10n-mozilla-beta/search?string=types\..\.title%3DGoogle&regexp=1&find=browser&findi=&filter=^[^\0]*%24&hitlimit=&tree=l10n-mozilla-beta
Filed bug 906688 and sent instructions to dev-1l0n.
Flags: needinfo?(milos)

Updated

6 years ago
Blocks: 943318
You need to log in before you can comment on or make changes to this bug.