If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

FTP at releases.mozilla.org slow / unresponding and non-reliable

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
P4
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: hummelbrunner, Assigned: solarce)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130307075451

Steps to reproduce:

Connecting to releases.mozilla.org via FTP then trying to get a directory listing after CD'ing to pub/mozilla.org.


Actual results:

Upon issuing the DIR-command, 2 Messages come back:
200 PORT command successful. Consider using PASV.
150 Here comes the directory listing.
And then the connection seemingly freezes.
Aborting with Ctrl+C doesn't seem to really kill the stream as the program still hangs at this point.


Expected results:

A directory listing of pub/mozilla.org should've been given.
(Reporter)

Updated

5 years ago
Severity: normal → major
What IP address does releases.mozilla.org resolve to for you?
(Reporter)

Comment 2

5 years ago
Standardserver:  auth.mpia-hd.mpg.de
Address:  149.217.41.6

> releases.mozilla.org
Server:  auth.mpia-hd.mpg.de
Address:  149.217.41.6

Non-authoritative answer:
Name:    releases.geo.mozilla.com
Addresses:  216.165.129.141
          64.50.236.214
          155.98.64.83
          156.56.247.196
          202.177.202.154
          204.246.0.136
Aliases:  releases.mozilla.org
Most of those machines are mirrors outside of the mozilla network, with the exception of pj-mirror01.mozilla.org which is in Japan and will be slow.

What are you trying to accomplish? releases.mozilla.org is likely not the best way to do it.

I'd suggest: ftp://ftp.mozilla.org/pub/mozilla.org/
(Reporter)

Comment 4

5 years ago
(In reply to Peter Radcliffe [:pir] from comment #3)
> Most of those machines are mirrors outside of the mozilla network, with the
> exception of pj-mirror01.mozilla.org which is in Japan and will be slow.
> 
> What are you trying to accomplish? releases.mozilla.org is likely not the
> best way to do it.
> 
> I'd suggest: ftp://ftp.mozilla.org/pub/mozilla.org/

I'm trying to get the latest release-versions of Firefox and thunderbird. ftp.mozilla.org specifically statets, that releases.mozilla.org should be used for that and that stable releases will return 550 PERMISSION DENIED from ftp.mozilla.org

Updated

5 years ago
See Also: → bug 850584
Where does ftp.mozilla.org state that?
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/
ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/latest/
https://ftp.mozilla.org/ states:

--
ftp.mozilla.org / archive.mozilla.org - files are here.

Notice: This server is the only place to obtain nightly builds and needs to remain available to developers and testers. High bandwidth servers that contain the public release files are available at releases.mozilla.org. If you need to link to a public release, please link to the release server, not here. Thanks!
--

releases.mozilla.org is not reliable between 156.56.247.196 not being a valid mirror (see bug 849875) and several others being too slow to respond (including pj-mirror01.mozilla.org, see bug 810280).

IMO we should drop that message entirely.

Updated

5 years ago
Depends on: 850584

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Assignee: server-ops → server-ops-webops
Component: Server Operations → Server Operations: Web Operations
QA Contact: shyam → nmaul
(Assignee)

Updated

5 years ago
Assignee: server-ops-webops → bburton
Severity: major → normal
Priority: -- → P4
(Assignee)

Comment 8

5 years ago
(In reply to hummelbrunner from comment #4)
> (In reply to Peter Radcliffe [:pir] from comment #3)
> > Most of those machines are mirrors outside of the mozilla network, with the
> > exception of pj-mirror01.mozilla.org which is in Japan and will be slow.
> > 
> > What are you trying to accomplish? releases.mozilla.org is likely not the
> > best way to do it.
> > 
> > I'd suggest: ftp://ftp.mozilla.org/pub/mozilla.org/
> 
> I'm trying to get the latest release-versions of Firefox and thunderbird.
> ftp.mozilla.org specifically statets, that releases.mozilla.org should be
> used for that and that stable releases will return 550 PERMISSION DENIED
> from ftp.mozilla.org

We'll work to amend that, as it's no longer true with the move to the CDN being the primary distribution method for binaries.

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/win32/en-US/ and other OS/lang work just fine now
(In reply to Peter Radcliffe [:pir] from comment #5)
> Where does ftp.mozilla.org state that?

In the first message I get when connecting. The example below is what happens when I connect by ftp to ftp.mozilla.org with a .netrc file in place. The hostname in the first line may vary, and the message always happens twice, IIUC once before getting the username (anonymous) and once before ge(tting the password (an email address).

Connected to ftp.dynect.mozilla.net.
220-
220-   ftp.mozilla.org / archive.mozilla.org - files are in /pub/mozilla.org
220-
220-   Notice: This server is the only place to obtain nightly builds and needs to
220-   remain available to developers and testers. High bandwidth servers that
220-   contain the public release files are available at ftp://releases.mozilla.org/
220-   If you need to link to a public release, please link to the release server,
220-   not here. Thanks!
220-
220-   Attempts to download high traffic release files from this server will get a
220-   "550 Permission denied." response.
220 
331 Please specify the password.
230-
230-   ftp.mozilla.org / archive.mozilla.org - files are in /pub/mozilla.org
230-
230-   Notice: This server is the only place to obtain nightly builds and needs to
230-   remain available to developers and testers. High bandwidth servers that
230-   contain the public release files are available at ftp://releases.mozilla.org/
230-   If you need to link to a public release, please link to the release server,
230-   not here. Thanks!
230-
230-   Attempts to download high traffic release files from this server will get a
230-   "550 Permission denied." response.
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
s/before/after/g
(Assignee)

Comment 11

5 years ago
I am not able to reproduce this behavior at this time

With the OSX ftp client I was able to obtain the Firefox 20 Windows installer

bburton@ironbars [03:55:19] [~]
-> % ftp ftp.mozilla.org
Connected to ftp.dynect.mozilla.net.
220-
220-   ftp.mozilla.org / archive.mozilla.org - files are in /pub/mozilla.org
220-
220-   Notice: This server is the only place to obtain nightly builds and needs to
220-   remain available to developers and testers. High bandwidth servers that
220-   contain the public release files are available at ftp://releases.mozilla.org/
220-   If you need to link to a public release, please link to the release server,
220-   not here. Thanks!
220-
220-   Attempts to download high traffic release files from this server will get a
220-   "550 Permission denied." response.
220
Name (ftp.mozilla.org:bburton): anonymous
331 Please specify the password.
Password:
230-
230-   ftp.mozilla.org / archive.mozilla.org - files are in /pub/mozilla.org
230-
230-   Notice: This server is the only place to obtain nightly builds and needs to
230-   remain available to developers and testers. High bandwidth servers that
230-   contain the public release files are available at ftp://releases.mozilla.org/
230-   If you need to link to a public release, please link to the release server,
230-   not here. Thanks!
230-
230-   Attempts to download high traffic release files from this server will get a
230-   "550 Permission denied." response.
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
229 Extended Passive Mode Entered (|||51752|)
150 Here comes the directory listing.
-rw-r--r--    1 ftp      ftp           528 Nov 01  2007 README
-rw-r--r--    1 ftp      ftp           561 Oct 03  2012 index.html
drwxr-xr-x   47 ftp      ftp          4096 Apr 06 09:53 pub
226 Directory send OK.
ftp> cd pub

>>> snip >>>>

226 Directory send OK.
ftp> cd en-US
250 Directory successfully changed.
ftp> ls
229 Extended Passive Mode Entered (|||52723|)
150 Here comes the directory listing.
-rw-r--r--    1 ftp      ftp      21041840 Mar 27 02:33 Firefox Setup 20.0.exe
-rw-r--r--    1 ftp      ftp        236920 Mar 27 02:33 Firefox Setup Stub 20.0.exe
226 Directory send OK.
ftp> get Firefox\ Setup\ 20.0.exe
local: Firefox Setup 20.0.exe remote: Firefox Setup 20.0.exe
229 Extended Passive Mode Entered (|||51940|)
150 Opening BINARY mode data connection for Firefox Setup 20.0.exe (21041840 bytes).
100% |******************************************************************************************************************************************************************************************************************| 20548 KiB    4.36 MiB/s    00:00 ETA226 Transfer complete.
21041840 bytes received in 00:04 (4.36 MiB/s)
ftp>

Is there any reason you can't obtain your download from http://www.mozilla.org/en-US/firefox/fx/#desktop ? This will use our CDN and give you the fastest download experience
(Reporter)

Comment 12

5 years ago
(In reply to Brandon Burton [:solarce] from comment #11)
> I am not able to reproduce this behavior at this time

The problem was with releases.mozilla.org NOT ftp.mozilla.org
As you posted, ftp.mozilla.org still states that normal releases should be obtained from releases.mozilla.org, which is unreliable.

> Is there any reason you can't obtain your download from
> http://www.mozilla.org/en-US/firefox/fx/#desktop ? This will use our CDN and
> give you the fastest download experience

The problem is that I need to get specific language versions via a script. While I could get those via the weblink and wget. It's easier for me to do this with a FTP-connection.
(In reply to Brandon Burton from comment #8)
> (In reply to hummelbrunner from comment #4)
> > ftp.mozilla.org specifically statets, that releases.mozilla.org should be
> > used for that and that stable releases will return 550 PERMISSION DENIED
> > from ftp.mozilla.org
> 
> We'll work to amend that, as it's no longer true with the move to the CDN
> being the primary distribution method for binaries.

Filed bug 867926.
See Also: → bug 871120
See Also: bug 871120
(Assignee)

Updated

4 years ago
Assignee: bburton → server-ops-webops
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
(Assignee)

Comment 14

4 years ago
* releases.mozilla.org now only works for HTTP traffic and uses our CDN partners for downloads.
* ftp.mozilla.org is our high bandwidth (multiple 10Gb routes to the internet) FTP and HTTP origin, you should use this for ftp requests going forward
 * relevant index and README files have been updated, in bug 867926, to reflect this current reality

Please let us know if there are any questions and thanks for using Firefox!
Assignee: server-ops-webops → bburton
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.