Last Comment Bug 851117 - Repack comm-aurora using in-tree mozconfigs, objdirs, and pre-built mar tools
: Repack comm-aurora using in-tree mozconfigs, objdirs, and pre-built mar tools
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Build Config (show other bugs)
: 21 Branch
: All All
: P2 critical (vote)
: ---
Assigned To: Chris Cooper [:coop]
:
Mentors:
Depends on:
Blocks: 784848
  Show dependency treegraph
 
Reported: 2013-03-14 08:45 PDT by Chris Cooper [:coop]
Modified: 2013-03-28 05:56 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
comm-aurora changes required for repacking l10n on win64, using mozconfigs, objdirs, and pre-built mar tools (14.79 KB, patch)
2013-03-14 15:32 PDT, Chris Cooper [:coop]
standard8: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Chris Cooper [:coop] 2013-03-14 08:45:18 PDT
These changes are going live for Firefox and comm-central today, but comm-aurora repacks will break until the patch in https://bugzilla.mozilla.org/attachment.cgi?id=720094 is uplifted.

I'll re-attach the patch here and try to flag it appropriately to get some traction.
Comment 1 Chris Cooper [:coop] 2013-03-14 14:03:14 PDT
I'm trying to be conscientious and test the patch against comm-aurora. Unfortunately a straight uplift of my patch(es) from comm-central is failing, so trying to debug that. More info as I unravel it.
Comment 2 Chris Cooper [:coop] 2013-03-14 15:27:08 PDT
(In reply to Chris Cooper [:coop] from comment #1)
> I'm trying to be conscientious and test the patch against comm-aurora.
> Unfortunately a straight uplift of my patch(es) from comm-central is
> failing, so trying to debug that. More info as I unravel it.

Turns out it was just aurora-specific path differences in how we need to set --with-l10n-base. Patch incoming.
Comment 3 Chris Cooper [:coop] 2013-03-14 15:32:02 PDT
Created attachment 725139 [details] [diff] [review]
comm-aurora changes required for repacking l10n on win64, using mozconfigs, objdirs, and pre-built mar tools

[Approval Request Comment]
Regression caused by (bug #): bug 784848
User impact if declined: comm-aurora repacks will remain disabled
Testing completed (on c-c, etc.): c-aurora in releng dev env
Risk to taking this patch (and alternatives if risky): we're uplifting of some build config code prior to merge day, but this has already happened for mozilla-aurora.
Comment 4 Mark Banner (:standard8) 2013-03-18 06:03:04 PDT
Comment on attachment 725139 [details] [diff] [review]
comm-aurora changes required for repacking l10n on win64, using mozconfigs, objdirs, and pre-built mar tools

+ac_add_options --with-l10n-base=../../releases/l10n/mozilla-aurora

Just a thought (and could be done with a follow-up) does this dir need to have a repo specific name? If it was repo-independent it'd mean one less change to mozconfigs on merge day (although I automate it all for comm-central anyway, so not a huge issue).
Comment 5 Chris Cooper [:coop] 2013-03-18 09:24:35 PDT
Comment on attachment 725139 [details] [diff] [review]
comm-aurora changes required for repacking l10n on win64, using mozconfigs, objdirs, and pre-built mar tools

https://tbpl.mozilla.org/?tree=Thunderbird-Aurora&rev=ef46eb538736
Comment 6 Chris Cooper [:coop] 2013-03-18 09:25:14 PDT
(In reply to Mark Banner (:standard8) from comment #4) 
> +ac_add_options --with-l10n-base=../../releases/l10n/mozilla-aurora
> 
> Just a thought (and could be done with a follow-up) does this dir need to
> have a repo specific name? If it was repo-independent it'd mean one less
> change to mozconfigs on merge day (although I automate it all for
> comm-central anyway, so not a huge issue).

We want the same thing on the Firefox side. I'll file a follow-up.
Comment 7 Mark Banner (:standard8) 2013-03-28 05:56:47 PDT
https://hg.mozilla.org/releases/comm-aurora/rev/ef46eb538736

Note You need to log in before you can comment on or make changes to this bug.