Text input element becomes unresponsive to text input

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: litzomatic, Unassigned)

Tracking

19 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Click the input field to gain focus THEN select the text in the input field.  Typing does nothing then.

I was able to reproduce this with an absolutely positioned div containing an input element absolutely positioned over top of a ustream video embedded inside of an iframe.

A succinct example in HTML is below.

<!DOCTYPE HTML>
<div style="position: absolute;">
  <input type="text" value="I'm giving her all she's got, Captain!" />
</div>
<iframe width="600" height="369"
src="http://www.ustream.tv/embed/13561842?v=3&amp;wmode=direct"
scrolling="no" frameborder="0" style="border: 0px none transparent;">
</iframe>

System Info:

  Firefox 19.02

  Model Name:	MacBook Pro
  Model Identifier:	MacBookPro10,1
  Processor Name:	Intel Core i7
  Processor Speed:	2.3 GHz
  Number of Processors:	1
  Total Number of Cores:	4
  L2 Cache (per Core):	256 KB
  L3 Cache:	6 MB
  Memory:	16 GB


Actual results:

I cannot enter text into the input element, nor delete the text inside the input element.


Expected results:

I should be able to delete and enter text inside of a text input element.

Comment 1

6 years ago
it works if wmode=opaque or transparent.
(Reporter)

Comment 2

6 years ago
I tried to confirm that it works with wmode=opaque and wmode=transparent and it does not.  The bug reproduces with wmode=opaque and wmode=transparent for me.

Are you sure you just didn't have the inspector open? The bug does not reproduce with the inspector open.

Comment 3

6 years ago
The following html works for me.

<!DOCTYPE HTML>
<div style="position: absolute;">
  <input type="text" value="I'm giving her all she's got, Captain!" />
</div>
<iframe width="600" height="369"
src="http://www.ustream.tv/embed/13561842?v=3&amp;wmode=opaque"
scrolling="no" frameborder="0" style="border: 0px none transparent;">
</iframe>
(Reporter)

Comment 4

6 years ago
Interesting, the HTML does not work for me.

I click to gain focus, then once I select the text after gaining focus, I'm unable to enter or delete text and receive the alert bell on each key press.

Are you trying to reproduce on a Mac or is your test on Linux/Windows?  I have access to other versions/hw of Mac OS, but not to a Linux device ATM.
Hello Derek,

sorry for this late response, but I just made a test and it WORKSFORME.
can you maybe make a short test on your system with an actual version of firefox?

thank you for your helt to make firefox better.
Flags: needinfo?(litzomatic)

Comment 6

3 years ago
I have the same problem on Firefox Nightly 47.0a1 which I installed two days ago about at 2016-02-11 00:48:32 PST and still occurs after several Nightly updates.

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160211075855 

Before I switched to Firefox Nightly 47.0a1, I was on a normal version of Firefox (Firefox 44.01 and previous) and I had no such problems. So the problem seems to be Nightly exclusive.

This happened several times already while typing comments on bugzilla.

This happens randomly on random websites while trying to:
- type a text into a text field
- select text in a text field
- remove text from a text field

The text input freezes and also the char indicator dissapear and when I switch to another tab and back after several seconds, the problem dissapears. Then may (but not must) appear again.

Comment 7

3 years ago
(Althought I have no problem on a succinct example in HTML given by Derek Litz in UserStory.)

Comment 8

3 years ago
I made a fresh profile, but that did not help, so I switched back to my profile.

And then I disabled

> Options >> General >> Startup >> Enable multi-process Nightly

and restarted Nightly, and all the three problems:

https://bugzilla.mozilla.org/show_bug.cgi?id=1248120
https://bugzilla.mozilla.org/show_bug.cgi?id=1248125
https://bugzilla.mozilla.org/show_bug.cgi?id=851133

dissapeared as if by magic.

So the cause of all the problems is the multi-process.

However I'm not sure if the problems (bugs) may be considered as resolved (closed), as disabling the multi-process is just a workaaround and the real solution is to fix the multi-process.

Updated

3 years ago
tracking-e10s: --- → ?

Comment 9

3 years ago
Hi Marcino245,

Can you provide a testcase where you can reproduce this issue?
Flags: needinfo?(marcino245)

Comment 10

3 years ago
Hello,
sorry, I forgot to mention here that the bug is gone for me, as I mentioned here >> Bug 1248146
Flags: needinfo?(marcino245)

Updated

3 years ago
tracking-e10s: ? → ---
Based on comment 3, 5, 10, I will mark this as resolved WFM. Feel free to reopen it if you still reproduce the problem on the latest Firefox version, and also please add the steps or a test case where we can see the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(litzomatic)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.