If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Camera] Lock Screen: Camera doesn't get LazyLoader when loaded from LockScreen

VERIFIED DUPLICATE of bug 853420

Status

Firefox OS
Gaia::Camera
VERIFIED DUPLICATE of bug 853420
5 years ago
5 years ago

People

(Reporter: Allen Maxwell, Assigned: mikeh)

Tracking

({smoketest})

unspecified
ARM
Gonk (Firefox OS)
smoketest

Firefox Tracking Flags

(b2g18 fixed, b2g18-v1.0.1 fixed)

Details

(Whiteboard: future dup)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 724954 [details]
LogCat of event

Description:
When user opens camera from the locked screen, with phone lock enabled, the phone has an OOM event

Repro Steps:
1) Updated to Unagi Build ID: 20130314070204
2) Set passcode on phone (settings/phone lock)
3) Lock the screen (press power button)
4) Press power button
5) Press camera icon

Expected:
Camera launches and allows user to take pictures.

Actual:
The camera app stops loading (OOM)

Repro frequency:
100%, 2/2

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/dc3add076016
Gaia: 1e1c8c0ff2bc7f252fbe95016f108e38ece691a9

Notes:
Works with passcode disabled camera launches normally
Q Analysts Test Team Priority Rating: Pri 1
The logcat doesn't show anything.

How can you tell this is an OoM condition?  What exactly happens on the screen when you follow the STR?

I can't reproduce with the STR using mozilla-inbound; will try with b2g18.
(Reporter)

Comment 2

5 years ago
Created attachment 725135 [details]
Screenshot
(Reporter)

Comment 3

5 years ago
Appeared as a crash but no crash report was generated 
Screenshot attached

Does not occur on:
Unagi Build ID: 20130313070202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/2a8c49f56bb6
Gaia: acd6546cdd03284b3b8c12432fb9955868fc4c2b

Still occurs on:
Unagi Build ID: 20130314114915
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8e9dd87b4f3b
Gaia: 69dbcd84085f10bec0c0189b926ffb535b14dcfe
I can reproduce this error and see this in my logcat:

E( 2775:0xad7) [JavaScript Error: "ReferenceError: LazyLoader is not defined" {file: "app://system.gaiamobile.org/camera/js/camera.js" line: 3}]

I'm running:
- gecko: b2g18:a827df06cffb
- gaia: 686932e12a459848be29eb407991383dfb45b8af

djf, I just noticed there's a whole second copy of the camera in $GAIA/apps/system/.  I don't see it in github, so I assume it's copied from $GAIA/apps/camera/ as part of the build/install process.

The copied index.html includes:
    <script defer src="shared/js/lazy_loader.js"></script>

...but I'm guessing that relative path is no good for accessing the LazyLoader?  (Does that mean we'll have to copy the LazyLoader into the system folder as well??)
Flags: needinfo?(dflanagan)
Yes, it is just a straight copy of the camera app in the system app. The other shared files used by camera use absolute paths, so maybe changing adding a / prefix in apps/camera/index.html would fix it.

But there have also been a number of bugs on v1.0.1 because the patch that introduced LazyLoader did not get uplifted before the patches that use it.  So if you're seeing this on a v1.0.1 build it is probably because of that and will go away as soon as lazy_loader.js gets uplifted.

And if that is not it, then maybe it is an issue with the build system not being smart enough to copy the shared files for this copy of the camera app to where they need to go. You could probably fake it out, if necessary, by adding a commented out script to apps/system/index.html.
Flags: needinfo?(dflanagan)
Created attachment 725170 [details]
Github PR - make relative path to lazy_loader.js absolute

I've confirmed that with this change, the camera app (still) works and the lockscreen-with-passcode camera works (again).
Assignee: nobody → mhabicher
Status: NEW → ASSIGNED
Attachment #725170 - Flags: review?(dflanagan)
Comment on attachment 725170 [details]
Github PR - make relative path to lazy_loader.js absolute

Trivial r+. Mike says he has tested and that it fixes the bug.

The travis build failed with an unrelated error in the Calendar app.

Merged into master: https://github.com/mozilla-b2g/gaia/commit/73256c6d67a87731430cb303a546c9ab06533b90
Attachment #725170 - Flags: review?(dflanagan) → review+

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 8

5 years ago
leo+, may end up being tef+ if v1.0.1 is affected (adding qawanted).
blocking-b2g: leo? → leo+
status-b2g18: --- → affected
Keywords: qawanted
Uplifted commit 73256c6d67a87731430cb303a546c9ab06533b90 as:
v1-train: c70409129248807ec392fef7065d806d8ab6dacb
status-b2g18: affected → fixed
Summary: [B2G][Camera] Lock Screen: Camera has an OOM event when opening from lock screen with phone lock enabled → [B2G][Camera] Lock Screen: Camera doesn't get LazyLoader when loaded from LockScreen
Yes, this affects 1.0.1 as well:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/4931ec89ebbe
Gaia   c33b1f8b60edc223ba86dd22f912effee990132a
BuildID 20130327070203
Version 18.0
status-b2g18-v1.0.1: --- → affected
Keywords: qawanted
noming for tef based on comment 8.
blocking-b2g: leo+ → tef?
Flags: needinfo?(akeybl)
Its a trivial one-character patch. Should be easy to triage :-)
(In reply to Naoki Hirata :nhirata from comment #11)
> noming for tef based on comment 8.

Not my call, but I agree we should block for tef+.
Flags: needinfo?(akeybl) → needinfo?(mvines)
(passing the buck here, because I'm out of the tef+ biz now)
Flags: needinfo?(mvines) → needinfo?
(Reporter)

Comment 15

5 years ago
This issue is still reproducable on 3/28 Commercial and Mozilla RIL:
Build ID: 20130328070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/dc653b5b2339
Gaia: 6dbf0b68622aa80d079fee2af660ddc47f7cd7df
Status: RESOLVED → REOPENED
Flags: needinfo?
Resolution: FIXED → ---
Looks like the patch is applied in master and v1-train, but not v1.0.1.
It seems that patch at bug 853420 should be enough to solve this issue, right?
Flags: needinfo?(mhabicher)
Marking it as duplicated of bug 853420 to ease tracking.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853420

Updated

5 years ago
blocking-b2g: tef? → ---
status-b2g18-v1.0.1: affected → fixed
(In reply to Daniel Coloma:dcoloma from comment #17)
>
> It seems that patch at bug 853420 should be enough to solve this issue, right?

Looks like it will, yes.
Flags: needinfo?(mhabicher)

Comment 20

5 years ago
confirming - the issue has been fixed, 

as per comment #7 in bug 853420 "User no longer has to put in the screen lock code in order to use camera"

tested on both, v1.0.1 and v1-train

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/45aa5ba0ed53
Gaia   cf2d4136f0ebc66039637fdbeb72ed184dfbc0f2
Build  20130429070204
Version 18.0
Inari

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/6c2493de1441
Gaia   c9046a7acef33328977840176ff5574720d2c74c
Build  20130426070204
Version 18.0
Leo
Status: RESOLVED → VERIFIED
(Reporter)

Updated

5 years ago
Whiteboard: future dup
You need to log in before you can comment on or make changes to this bug.