After page is moved, new page is not created and history of original page is lost

RESOLVED FIXED

Status

Mozilla Developer Network
General
P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: markg, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:bug])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
What did you do?
================
1. Choose "Move this page" on this URL:
https://developer.mozilla.org/en-US/docs/SpiderMonkey/JSAPI_Reference/Jsval

2. Tell it to move it to this URL:
https://developer.mozilla.org/en-US/docs/SpiderMonkey/JSAPI_Reference/JS::Value 

3. Click Save changes.

What happened?
==============
Got a 404 error on the new page. I tried the move twice.

What should have happened?
==========================
The new page /en-US/docs/SpiderMonkey/JSAPI_Reference/JS::Value should have been created with the old content from /en-US/docs/SpiderMonkey/JSAPI_Reference/Jsval, inclduing its history.

Is there anything else we should know?
======================================
Today the behavior of the original page has changed. If you go to /en-US/docs/SpiderMonkey/JSAPI_Reference/Jsval it redirects somewhere and gets a 404.
Also worth noting, the history of the Jsval page is completely gone.

https://developer.mozilla.org/en-US/docs/SpiderMonkey/JSAPI_Reference/Jsval$history

Let's keep this bug for fixing the underlying problem. I will open a separate bug for manually restoring the Jsval page for now.
Priority: -- → P1
Summary: No new page created with "Move this page" command → After page is moved, new page is not created and history of original page is lost
Opened bug 851210 for restoring the Jsval page manually in the meantime.
Looks like the db I need to look at is wiki_mdc_deki and the tables are "old" for the history and "pages" for the content. (stop me if this is wrong...)
Hrm, I recall groovecoder told me it was the developer_mozilla_org database, so I checked and am finding stuff in wiki_document and wiki_revision. Will search there first.
Oof, ignore those comments, they should have gone into https://bugzilla.mozilla.org/show_bug.cgi?id=851210 instead. My apologies!
Whiteboard: [specification][type:bug] → [specification][type:bug][selected]
Might only be new pages with certain characters in it? (e.g., ':')
Created attachment 734826 [details]
Moved Jsval page
I'm having trouble reproducing this locally. A local unit test passes just fine:

https://github.com/groovecoder/kuma/compare/page-move-bug-851199

And the attached screenshot shows the doc moved as expected - left behind a redirect and preserved history at the new slug.

Can we retry a page move like this in a test/user space? Under https://developer.mozilla.org/en-US/docs/User:markgiffin maybe?
Flags: needinfo?(m1879)
(Reporter)

Comment 9

5 years ago
(In reply to Luke Crouch [:groovecoder] from comment #8)
> Can we retry a page move like this in a test/user space? Under
> https://developer.mozilla.org/en-US/docs/User:markgiffin maybe?

I created this page:

https://developer.mozilla.org/en-US/docs/User:MarkGiffin/page_to_move

I tried to move it to this new slug:

/en-US/docs_en-US/docs/User:MarkGiffin/sandbox/moved_page

Result: 404 error reported at that URL. Also, the original page now also gives a 404:

https://developer.mozilla.org/en-US/docs/User:MarkGiffin/page_to_move
Flags: needinfo?(m1879)
(Reporter)

Comment 10

5 years ago
Also, here is the URL for the original page after the attempted move:

https://developer.mozilla.org/en-US/docs_en-US/docs/User:MarkGiffin/sandbox/moved_page?redirectlocale=en-US&redirectslug=User%253AMarkGiffin%252Fpage_to_move
(Reporter)

Comment 11

5 years ago
FYI, I'm on Windows 7 Pro using Google Chrome Version 26.0.1410.43 m.
Whiteboard: [specification][type:bug][selected] → [specification][type:bug]
I'm still not able to reproduce this.

:retornam, can you try to reproduce this bug on https://developer.allizom.org/en-US/ ?
Flags: needinfo?(mozbugs.retornam)
(In reply to Luke Crouch [:groovecoder] from comment #12)
> I'm still not able to reproduce this.
> 
> :retornam, can you try to reproduce this bug on
> https://developer.allizom.org/en-US/ ?

I haven't been able to reproduce this. I'll try again today to see if I'm able to.
Flags: needinfo?(mozbugs.retornam)
Blocks: 863449
Blocks: 863692
No longer blocks: 863449, 863692
https://developer.allizom.org/en-US/docs/HTML/HTML7$history moved a couple of times and stil no 404
(Reporter)

Comment 15

5 years ago
Well I tried it again and I could move a page using Firefox 21 beta, and also tried with Google Chrome, and now it works. So somebody musta fixed somethin' so thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.