Closed Bug 851224 Opened 9 years ago Closed 9 years ago

make install should ignore version downgrades

Categories

(Firefox for Android Graveyard :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 22

People

(Reporter: blassey, Assigned: capella)

Details

Attachments

(2 files)

JB throws an error for version downgrades unless you specifically override it. this makes bisecting hard amongst other things.
Attachment #725031 - Flags: review?(mark.finkle)
Attachment #725031 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/dc796f4da835
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
The addition of '-d' to 'adb install' in mobile/android/build.mk caused the build_and_deploy target to fail on older Android systems.  The flag appears to be passed through to 'pm' and this fails.
Tested locally ...

Prior to change:

Verification succesful
make -s --no-print-directory -j9 -C ./objdir-droid install
560 KB/s (21598767 bytes in 37.654s)
Error: Unknown option: -d
usage: pm list packages [-f] [-d] [-e] [-s] [-3] [-i] [-u] [FILTER]
...

After change:

Verification succesful
make -s --no-print-directory -j9 -C ./objdir-droid install
606 KB/s (21598777 bytes in 34.801s)
	pkg: /data/local/tmp/fennec-22.0a1.en-US.android-arm.apk
Success
Attachment #729013 - Flags: review?(mark.finkle)
Comment on attachment 729013 [details] [diff] [review]
Backout the change due to regressions

Backing out because this changed has caused a lot of grief for developers when the -d is not supported on the device. We could add code to version sniff the device, but in the meantime, let's remove it.
Attachment #729013 - Flags: review?(mark.finkle) → review+
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/2a388b6b49e7
Assignee: nobody → markcapella
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
build.py could check whether the device's API Level >= 17 and include then include the -d parameter:

adb shell getprop ro.build.version.sdk
17
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.