Status

Thunderbird
Search
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: hinst, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

I typed a word in the Search... field and clicked "Search" button


Actual results:

I get "No messages match your search" no matter what I type. 


Expected results:

For example, if I search for "Micr" there obviously should be some matching messages because I receive letters from "Microsoft Email" and these letters are displayed in the letter list.

Version: 17.0.4 Portable. 
The issue also was present in previous versions (17.0.x). In fact, search feature didn't work for me from the very beginning and didn't start to work after I updated Thunderbird 2 or 3 times. Not that I expected it to...
There are several kinds of "Search" in Tb.
Which?
(a) Global Search
(b) "Search Box"(Filter these messages) in Quick Filter Bar
(c) Find/Edit/Search Messages, Search Mesaages... of Folder context menu
(d) (Saved) Search Folder
(e) Customized View of "View" 

Please note that, if Global Search, Micr != Microsoft, because indexing is token basis and search is also token basis and search like "start with", "end with", "contains", is not implemented yet. Further, IIRC, token length is "longer than 3 chars"("the" is not indexed).

Comment 2

5 years ago
(In reply to WADA from comment #1)
> There are several kinds of "Search" in Tb.
> Which?
> (a) Global Search
> (b) "Search Box"(Filter these messages) in Quick Filter Bar
> (c) Find/Edit/Search Messages, Search Mesaages... of Folder context menu
> (d) (Saved) Search Folder
> (e) Customized View of "View" 
> 
> Please note that, if Global Search, Micr != Microsoft, because indexing is
> token basis and search is also token basis and search like "start with",
> "end with", "contains", is not implemented yet. Further, IIRC, token length
> is "longer than 3 chars"("the" is not indexed).
Flags: needinfo?(hinstance)
Whiteboard: [closeme 2013-04-11]
(Reporter)

Comment 3

5 years ago
I used Global Search. I didn't know that it works that way. So it turns out that this bug is not a bug.
Flags: needinfo?(hinstance)

Comment 4

5 years ago
Resolved per whiteboard and Comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2013-04-11]
If I understand correctly, definition of "RESOLVED/WORKSFOME" at bugzilla.mozilla.org is (a) "Tb's bug==Flaw in code of Tb" actually existed, and (b) The actual "Tb's bug==Flaw in code of Tb" has been fixed by unknown patch by unknown bug report, or by unknown change(s) in Tb.
Why can this bug be "RESOLVED/WORKSFOME" at bugzilla.mozilla.org even though "(a) is true" is never proved?

Closing as INVALID, because nothing about "evidence of that (a) is true" was provided by bug opener in this bug at buzilla.mozilla.org.
Resolution: WORKSFORME → INVALID
You need to log in before you can comment on or make changes to this bug.