Nightly 22 Components.interfaces.nsILivemarkService is undefined

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: denis@mgcash.com, Unassigned)

Tracking

22 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

I try to create livemarkservice instance

var s = Components.classes["@mozilla.org/browser/livemark-service;2"].getService(Components.interfaces.nsILivemarkService);


Actual results:

Failed to create instance, because Components.interfaces.nsILivemarkService is undefined


Expected results:

Components.interfaces.nsILivemarkService should be defined
(Reporter)

Updated

5 years ago
Version: 19 Branch → 22 Branch
(Reporter)

Updated

5 years ago
Summary: Nighly 22 Components.interfaces.nsILivemarkService is undefined → Nightly 22 Components.interfaces.nsILivemarkService is undefined

Comment 1

5 years ago
It was deprecated and removed. (see bug 838798)

mozIAsyncLivemarks appears to be the thing you should use instead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.