Closed Bug 851271 Opened 10 years ago Closed 10 years ago

additional Win8 reftest failures on inbound

Categories

(Core :: Layout, defect)

x86_64
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jimm, Assigned: jimm)

References

Details

Attachments

(2 files, 1 obsolete file)

https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=59611a3afcb3

12:35:46 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/svg/clipPath-and-shape-rendering-01.svg | image comparison (==), max difference: 1, number of differing pixels: 3 
12:36:57 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/transform-3d/scale3d-all.html | image comparison (==), max difference: 143, number of differing pixels: 681
12:36:57 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/transform-3d/scale3d-all-separate.html | image comparison (==), max difference: 143, number of differing pixels: 681 

Nothing serious, look like we just need to fuzzy a few more tests.
(In reply to Jim Mathies [:jimm] from comment #0)
> https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=59611a3afcb3
> 
> 12:35:46 INFO - REFTEST TEST-UNEXPECTED-FAIL |
> file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/svg/clipPath-
> and-shape-rendering-01.svg | image comparison (==), max difference: 1,
> number of differing pixels: 3 

We already annotated this 1,2 so I'll up it to 1,5.

> 12:36:57 INFO - REFTEST TEST-UNEXPECTED-FAIL |
> file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/transform-3d/
> scale3d-all.html | image comparison (==), max difference: 143, number of
> differing pixels: 681
> 12:36:57 INFO - REFTEST TEST-UNEXPECTED-FAIL |
> file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/transform-3d/
> scale3d-all-separate.html | image comparison (==), max difference: 143,
> number of differing pixels: 681 

These were already annotated for d2d but the max was set at 680. Upping that to 685.
Attached patch patchSplinter Review
Assignee: nobody → jmathies
Attachment #725075 - Flags: review?(mbrubeck)
Attachment #725075 - Flags: review?(mbrubeck) → review+
The transform-3d tests aren't fixed yet. Something in the fuzzy rules didn't catch for accelerated tests. I've pushed a new patch to try with reordered rules.

https://tbpl.mozilla.org/?tree=Try&rev=857c8082bbe6
Whiteboard: [leave-open]
Attached patch follow up (obsolete) — Splinter Review
Comment on attachment 725456 [details] [diff] [review]
follow up

I've removed the first 'winWidget&&!layersGPUAccelerated' test, since we now fail whether we have accelerated layers or not. Plus this was tripping up the test harness somehow such that the d2d rule was being ignored.

green try run:

https://tbpl.mozilla.org/?tree=Try&rev=857c8082bbe6
Attachment #725456 - Attachment description: patch v.2 → follow up
Attachment #725456 - Flags: review?(mbrubeck)
Comment on attachment 725456 [details] [diff] [review]
follow up

ugh, wrong patch.
Attachment #725456 - Attachment is obsolete: true
Attachment #725456 - Flags: review?(mbrubeck)
Attached patch follow upSplinter Review
right patch
Attachment #725462 - Flags: review?(mbrubeck)
Summary: additional ref test failures on inbound → additional Win8 reftest failures on inbound
Attachment #725462 - Flags: review?(mbrubeck) → review+
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [leave-open]
You need to log in before you can comment on or make changes to this bug.